1. #1

    Total loss of control in AC: Rogue

    I've been playing Rogue since Christmas in the late hours of the evening after putting the kids to bed. Finally completed the main story a few days ago and have now been hunting round for all the achievements.

    I tracked down all the Templar items from the maps and retrieved the Templar armour. After collecting the armour from the vault my game got stuck on a loading screen. I left it for about 10 minutes but it was definitely not going anywhere.

    So I turned off the Xbox 360, and turned it back on then loaded up my game.

    I spawned aboard my ship but the game is glitched. I see no on-screen indicators what-so-ever and my ship just slowly drifts forwards. I can not use the left stick to steer, nor can I fire any weapons. I can't even press the back button to view the map or press B to leave the wheel. In fact, the only inputs on the controller that do anything are the right stick (moving the camera) and the Y button (look behind).

    I was able to press the start button to return to the menu. I chose to leave the animus and managed to walk round Abstergo finding the remaining computers for that achievement. I returned to my Animus and was stuck aboard my boat again, unable to control it.

    Does anyone know if this bug has been reported? I guess something is glitched in my save game. Shame as I only had a handful of achievements left to get and I'm guessing the only thing I can do to fix this issue is to delete my save.
    Share this post

  2. #2
    Update: Managed to some how fix the error. I first looked on my Xbox 360 storage and found I had two save games one with A and one with B on the end. I tried removing them (copying to USB drive) and then tried loading with just A on my hard drive or just B. Neither made any difference.. so then I just loaded the game and let my ship sailing forwards (slowest speed since I couldn't even press A to speed up). After the ship crashed in to land, then in to an iceberg, then through some ice and finally was about to hit land again..

    The game suddenly switched as if I was picking up the Templar Armour again and I was opening the vault. The vault animation was all screwed up as the golden rings were stuck in position and did not animate with the door.. The armour also was not on the wooden stand (since I'd already collected it). I then saw Shay wearing the armour and had control of him again.

    Yay
    Share this post

  3. #3
    funny! well, actually not. it happens on ps3, xbox and on PC for me now. after getting templar armor. unfortunately it doesn't reset to the armor for me, no matter how much i crash and let it sail...
    Share this post

  4. #4
    Ubi-Swaggins's Avatar Ubisoft Support Staff
    Join Date
    Nov 2017
    Posts
    2,800
    Hey IP-Angels-Chaos,

    I am sorry to hear that! What platform do you experience this issue on?
    Share this post