1. #11
    En0-'s Avatar Trials Developer
    Join Date
    Jun 2011
    Posts
    1,775
    Hello,

    We found additional issues with NAT and matchmaking, we'll need some time to fix it.

    So, we're going to deploy a new version today or tomorrow with some fixes and improvements but that doesn't contain most of the fixes.

    We'll probably deploy another version next week with these fixes.

    Cheers,
    Share this post

  2. #12
    psycad's Avatar Member
    Join Date
    Mar 2014
    Location
    Quebec, Canada
    Posts
    272
    Please push these NAT fixes to Evo Gold as well, you know.. that game core fans really like. kthx.

    A company should keep supporting its products, and not just the most recent shiny one..
    Share this post

  3. #13
    En0-'s Avatar Trials Developer
    Join Date
    Jun 2011
    Posts
    1,775
    I know that you know it's not that simple
    Share this post

  4. #14
    BlueBadger400's Avatar Trials Community Specialist
    Join Date
    Nov 2013
    Location
    Winland
    Posts
    592
    Originally Posted by psycad Go to original post
    Please push these NAT fixes to Evo Gold as well, you know.. that game core fans really like. kthx.

    A company should keep supporting its products, and not just the most recent shiny one..
    I'm sure you know that it's not like flipping a switch and we are not doing it just because we don't wanna. Also Fusion PC version is made in collaboration with Ubisoft Kiev who had nothing to do with Gold Edition.
    Share this post

  5. #15
    So, I've tried forwarding *every* port mentioned here and on the official Ubi guides linked, and regardless of settings I still show Strict NAT, only way to get an open NAT on my end is via DMZ and as you can imagine this isn't ideal.

    Why oh why UPNP isn't being used in this day and age is beyond me, but either way, I can't allow unfiltered access to my system.
    Share this post

  6. #16
    En0-'s Avatar Trials Developer
    Join Date
    Jun 2011
    Posts
    1,775
    Originally Posted by ZeroNorthEast Go to original post
    So, I've tried forwarding *every* port mentioned here and on the official Ubi guides linked, and regardless of settings I still show Strict NAT, only way to get an open NAT on my end is via DMZ and as you can imagine this isn't ideal.

    Why oh why UPNP isn't being used in this day and age is beyond me, but either way, I can't allow unfiltered access to my system.
    We're improving this and seeing if UPNP could help.

    Thanks for the feedback,
    Share this post

  7. #17
    Glad to hear it, because I'd hate to hear so many people complain about this not working when it eventually is released, many people less technically savvy wouldn't have any idea where to start when it comes to port forwarding, and even if they know how, they might get stuck in the same boat as me whereby no amount of fiddling can get me an open NAT without seriously compromising their network integrity.

    At least when I can find players everything seems to work fine though, there's an odd gfx issue I seem to have but this thread isn't the place.
    Share this post

  8. #18
    I am going to cry soon.... I have this great looking multiplayer sitting there, begging e to play it, but I cannot find any people to play with. So is this because there is nobody there, or my NAT settings? Who knows.... Is there any way we can see how many people are playing / wanting to play so we can better identify if it is a problem at our end, your end, or somewhere in between??
    Share this post

  9. #19
    so, 3 years have passed.

    but I still can't play because it says that my NAT is strict.

    I have created virtual servers for each port designated here = https://support.ubi.com/en-US/faqs/0...-Issues-PC-TF/

    still says that NAT is strict. I don't understand why this only happens in Trials. Almost 10 years ago I remember having the same frustration whilst trying to play multiplayer of Trials Evolution. You should fire your network engineer team and hire a new one. I'm not joking.

    Why this hasn't been fixed? It's 2017 ffs.
    Share this post