1. #1

    Specific area crash during "Sermon on the Mount"

    Hello guys

    I posted this trouble on Support (#02145462) a couple of days ago but maybe someone could help me out with new ideas while I wait.

    So my game keeps crashing on "Sermon on the Mount" when I try to enter a cave while searching for the weapon shipments.
    Sometimes I can get a few steps inside the cave but the crash is inevitable.
    I tried going in there at different times but the result is always the same.

    10+ hours in and the game works fine with everything else, only that darn cave.
    I could even cancel the mission and continue playing on other stuff but now I kinda have to finish that one.

    i7-4770k @3,5 ghz
    1x MSI 770 Lightning
    16 GB RAM
    Windows 7 with latest drivers installed clean.

    GPU/CPU temp never above 65 C.

    Verifying doesn't work.
    Re-installing the game doesn't work.
    All settings to Low - no luck.

    Anyone got any advice for me?

    Share this post

  2. #2
    WID992007's Avatar Senior Member
    Join Date
    Sep 2007
    when you did your file verify were you running Steam (if you have the steam version) as well as the u play client as Run as Administrator ?

    this helps sometimes ... also try lowering your graphics settings sometimes works for some people ..especially if you used geforce experience to set up your game

    (in fact i didn't even install that when i installed my drivers under custom settings )

    i use a Asus Strix GTX 960 and just set my Graphics settings up using the in game settings using driver version 347.52 ..as that was the last driver that mentioned any performance increase for Far Cry 4

    SOFT Shadows is BORKED since Far Cry 4 version 1.8.0 i keep the shadow settings on HIGH and have had zero crash issues with the game since it launched in november

    previous Vid card was an Asus R 9 270 X 2 gig version ..again no crash issues and i only used the in game settings to set up my graphics ..again no Crash issues..

    here are my current Graphics settings with my GTX 960

    resolution 1920 X 1080

    Vsync - ON

    Motion Blur - OFF ..not a fan of how it looks

    Textures - Ultra

    Shadows - High

    Post Fx - Ultra

    Geometry -Very High

    Vegetation - Ultra

    Environment - Ultra

    Water - Ultra

    Ambient Occlusion - SSBC

    AntiAliasing - SMAA ... (TXAA works as well )

    Godrays - Off ..not a fan of it ..looks better on my 40 in HDTV if its off ..and can cause a performance hit ..at least on my system

    Fur - Off .. it makes a performance hit on my system if i enable it

    Trees relief - Off

    Advanced settings

    Triple Buffering - Off
    Vsync Mode - Normal

    your GTX 770 should do a lil better then my GTX 960 i would think ..tho my 960 is a factory overclocked Asus Card the 770 should enable you to bump a few things upward


    just stay clear of Soft Shadows ..that setting i can confirm is indeed still not working for many people with Nvidia graphics cards and causing a large performance hit since Patch 1.8.0
    Share this post

  3. #3
    I tried a cocktail of standard methods at once just now.
    Once again a clean install of nvidia drivers, ran CCleaner followed by a proper reboot.
    Launch the game, switch everything to the lowest setting and run in windowed mode.

    I'm not quite sure if that worked or if I got lucky but, omg, no crash.

    I don't know but it seems to me to be too specific a bug to be anything but a bug.
    I'm not trying to be a **** or anything but this cost me about three hours (plus another five during the re-download) so if indeed this was caused by the recent patch it should be looked into asap.

    Well that's what I did in case someone runs into something similar.

    Thanks for your time.
    Share this post

  4. #4
    The exact same thing is happening for me now, and I can't get past it.

    (insert all the usual files yadda yadda here)

    It's an obvious bug.
    Share this post

  5. #5
    Had the same issue, tried 4 times, 4 crashes in the cave. Then I read about fvrzer0's experience so I set graphics quality to low, chose a lower resolution, had the game in windowed mode. Tried again, got through the mission.
    Share this post

  6. #6
    UbiBooma's Avatar Community Representative
    Join Date
    Jun 2015
    Originally Posted by erdokovyz Go to original post
    Had the same issue, tried 4 times, 4 crashes in the cave. Then I read about fvrzer0's experience so I set graphics quality to low, chose a lower resolution, had the game in windowed mode. Tried again, got through the mission.
    Did you ever report this issue to the support team? That's the best way to address the issue --> ubi.support.com
    Share this post

  7. #7
    I did report it but it took support 6 days to react so I kept googling for ideas what to
    try and got lucky.

    By the way their response, after receiving my MSINFO logs, was to reinstall Direct X
    because during a crash d3d11.dll fails. However I'm not sure how I would go about
    doing that since according to Microsoft Direct X is maintained by Windows Update on
    Windows 10. I couldn't readily find an install package for manual reinstall. But then
    again I didn't look that hard. Anyway, this is some plus information on the matter.
    Share this post

  8. #8
    WID992007's Avatar Senior Member
    Join Date
    Sep 2007
    try to verify the game files as an ADMINISTRATOR

    its not a game bug as i have played thru the campaign 11 times now with no crash .. once with windows 10 Pro 64 bit twice on windows 8 home 64 bit and multiple times with windows 7 64 bit
    and have not had a single game breaking crash

    vid cards used

    AMD on board 8650 G on my laptop (win 8.1 Home 64 bit + windows 10 home 64 bit ) - everything on low using current AMD driver res 1280 X 720

    desktop cards used

    Asus R 9 270 X 2 gig card used AMD cat version 14.1 (windows 7 64 bit) (as it was months ago i had that card)

    best resolution for that card was 1600 X 900 with high settings

    most recent card i used with both windows 7 64 bit as well as windows 10 Pro 64 bit is an Asus Strix GTX 960 res 1920 X 1080
    drivers used
    347.52 - to current driver 355.82 (and yes the new win 10 Nvidia driver sucks.. so backdated to drivers that give me the best frame rates )

    my settings in game are posted above

    game works is also broken for many with various cards so it has to be a problem with the drivers ..as older drivers seem to work better https://forums.geforce.com/default/t...-in-far-cry-4/

    currently using 353.62 on windows 10 / 347.52 in windows 7

    Nvidia gameworks settings off

    its important to remember this game will stress a video card .. your gonna get crashes if ya set your setting too high
    use this page as kind a guide to see what your GPU can do .. again if you have any card lower the a GTX 750 ti your gonna have problems
    and by lower i mean performance wise ..not number wise .. face it a GTX 740 is not faster then a GTX 680 just because of the larger first number

    you need to look at everything from mem bandwidth to pixel and vertex shader numbers as well as chip version new chips will run better then older ones i e a GTX 960 is better then a gtx 760 in some benchmarks ..but not all.... the better card for FC4 = the 960 if you go by DX 11 benchmarks

    and remember laptop Chips are usually not = the their desktop counterparts

    to see how bad FAR CRY 4 stresses a GPU just look here .. http://www.hardocp.com/article/2015/.../#.Vf3elPlViko

    again i find it very interesting that they even said this at the end of the article about the low end cards

    Now we come to the cheapest cards in this evaluation, the GTX 750 Ti and Radeon R7 260X. The GTX 750 Ti is based on first generation Maxwell, and 260X is based on newer GCN than 290X or 290. However, even those architecture changes can't save these for performance. Neither one was able to play well at 1080p with any decent quality settings. To make either one playable at 1080p you'd have to play at "Low" settings, and turn off AO. Basically, it makes the game look like crap.
    Our only option was to drop the resolution to 720p, 1280x720. At this resolution we could raise the settings quite a bit, providing a better image quality in the game. We were able to set both to "Very High" settings, which is just one step down from "Ultra" quality. So even at 720p, these still cannot maximize image quality in the game, we still have to sacrifice some level of image quality. Also, no Godrays. So these video cards are very slow for this game despite these having newer architectures. These cards just can't cut it.

    so if your getting crashes lower your settings and resolution may be your only fix
    Share this post