1. #21
    Well well well...

    I have to say I'm now eating a few of my words... community/public service staff aside. *chortle*

    This game now runs good and proper on my gaming PC in my living room. Keep it up. The market is there turd burglars.

    Share this post

  2. #22

    Going to try that

    That for the patch and the email notification.
    I'm going to try that ASAP.
    Share this post

  3. #23

    4670K, GTX 760 4 GB, 8 GB RAM, 1280x1024 (it's small, ikr)

    All settings maxed out, FXAA, ultra textures - no change between previous version, game is unplayable when driving a car, TONS of stuttering;
    All settings maxed out, FXAA, high textures - a little bit less stuttering between previous version, but definitely less stuttering compared to ultra textures... still, there is some

    I should be able to play this game flawlessly with 4 GB of VRAM, God damn it!
    So, no change pretty much for me.
    Share this post

  4. #24
    Originally Posted by kamilo793 Go to original post
    4670K, GTX 760 4 GB, 8 GB RAM, 1280x1024 (it's small, ikr)

    All settings maxed out, FXAA, ultra textures - no change between previous version, game is unplayable when driving a car, TONS of stuttering;
    All settings maxed out, FXAA, high textures - a little bit less stuttering between previous version, but definitely less stuttering compared to ultra textures... still, there is some

    I should be able to play this game flawlessly with 4 GB of VRAM, God damn it!
    So, no change pretty much for me.
    Using ultra textures on a gtx 780 with custom capacitors and a cooler I built in my garage. Game runs remarkably different at all clock speeds including default EVGA speeds.

    Try updating to the newest Nvidia drivers, it ****ing helps a lot of games.

    Granted, I will say that maybe Nvidia optimized it but either way money is money and it is all one business these days. Who cares. Thanks for making it playable.
    Share this post

  5. #25
    Hi Nik_CtOS,

    Thanks for the update - it is definitely appreciated to see a developer post on here.

    To confirm my experience following this patch and installing Nvidia Driver 340.52

    High Textures - No stuttering. Definite improvement for me from last patch.
    Ultra Textures - Still stuttering. Some improvement however - stutters are generally less huge, but on the downside feel more frequent.

    All graphics settings on highest with exception of AA which is temporal SMAA

    My specs:

    i5 2500k @ 4.2GHZ
    8GB RAM
    Nvidia GTX 780 Ti (3GB)

    Look forward to your updates - would be really good if you were able to share a bit more detail about what the likely root cause is? Graphics memory buffer cleardown / other?

    Thanks, DMClues
    Share this post

  6. #26
    Rawrena's Avatar Banned
    Join Date
    Mar 2014
    Posts
    384
    Glad to hear that the Nvidia drivers + recent patch is helping with the stuttering for many of you guys. If you are experiencing any other issues, please make sure to contact support.ubi.com for further assistance.
    Share this post

  7. #27
    still no fix for me the first 4 mins of playing went ok.
    tried to play some online hacking because i was never been able to play that.
    then the lagging and stuttering started again it went from bad to worse just like before.
    so i was able to play a total of 9 mins.
    so another 2 months till the next patch ubi?
    Share this post

  8. #28
    I have installed the latest Nvidia drivers and the patch and it has helped a little bit but not completely. Maybe one more patch with more fixes will do it.
    Share this post

  9. #29
    dbzs's Avatar Junior Member
    Join Date
    Jul 2014
    Posts
    1

    I can't play the game after updating

    Originally Posted by isl91 Go to original post
    before the update , i played it once , then it stuck on the loading screen at 90% at the next time ....
    after the update , it stuck on the loading screen at 60% , then it stop working ..
    i can't play it ..
    I've got the same problem with you after the update, i can never get back into the game to play it suck at 65% and windows report it crash and turn it off.
    Hope someone can help us T.T
    Share this post

  10. #30
    Originally Posted by isl91 Go to original post
    before the update , i played it once , then it stuck on the loading screen at 90% at the next time ....
    after the update , it stuck on the loading screen at 60% , then it stop working ..
    i can't play it ..
    Turn off cloud saving in Uplay. It won't corrupt your saved games anymore.
    Share this post