🛈 Announcement
Greetings! Watch Dogs forums are now archived and accessible in read-only mode, please go to the new platform to discuss the game
  1. #1

    The Game Stutters on GTX 780 TI

    Hello. Watch dogs stutters on GTX 780 TI, 16 GB Ram and i7 4770K on High as well as Ultra textures, it stutters much more on ultra textures. Even when I walk it sometimes stutters but while driving it is much worse. Is it normal for this game and I should wait for patch or it is a problem with my hardware?
    Thank you for answers!
    Share this post

  2. #2

    Same issue

    Originally Posted by gawel72_PL Go to original post
    Hello. Watch dogs stutters on GTX 780 TI, 16 GB Ram and i7 4770K on High as well as Ultra textures, it stutters much more on ultra textures. Even when I walk it sometimes stutters but while driving it is much worse. Is it normal for this game and I should wait for patch or it is a problem with my hardware?
    Thank you for answers!
    I have the same issue with a similar rig setup with a 780 Ti
    Share this post

  3. #3

    Same here.

    Originally Posted by Mases2013 Go to original post
    I have the same issue with a similar rig setup with a 780 Ti
    This is absolutely ridiculous. Thankfully I got this game free with my 780Ti because if I had paid for it I would demand my money back. The product is not fit for purpose.
    My rig is as follows: i5 2500K O/C to 4.2, 8GB RAM and 780Ti, playing at 1080p on a Samsung EVO 128GB SSD.
    I get 60FPS easily when standing still and it drops and stutters like crazy whenever I do anything. Driving is a complete joke.
    My drivers are up to date, I am using "High" rather than "Ultra" Textures and "Ultra" everything else. Even when the settings are on low it stutters just as bad.
    I boot this game up every now and again to try and play because honestly, it does seem promising. However after 5 minutes or so I always end up turning it off in disgust. It is a thoroughly broken product. The latest official patch did nothing for the performance and the "Worse Mod" stuff made it look prettier but ultimately did nothing for the horrendous stuttering.
    Adding insult to injury, the game just doesn't look that good. "Sleeping Dogs" was released years ago and is comparable to this, without the ridiculous stuttering issues.
    I honestly don't know what to do with this game. I have uninstalled it out of rage about three times, then re-downloaded, and I'm apparently about 20% into the story, but god knows what the story is even about anymore because the atrocious performance has killed any interest I once had in it. Maybe we'll have to come back in a year or so to see if it is fixed, or maybe it won't ever be fixed because they have your money now.
    This game looked amazing when it was previewed. What we got was a lousy piece of half-baked, buggy software.
    Share this post

  4. #4
    Same setup as you but with an i5. Stutters on an SSD, even.

    So... Welcome to the Club! Let us all enjoy the amazing game Ubisoft developed with the PC as the LEAD PLATAFORM!

    All we can do is wait for the mythical patch. Maybe they will look into it after they are done patching consoles, the only plataforms that matter, apparently. After all, these problems are "pc only, who cares".
    Share this post

  5. #5
    Same here, 780 ti, 16GB ram, 4770k, running on an ssd. Stutters on ultra and on high even with effects turned off or low.
    Share this post

  6. #6
    Yes guys it happening to all kind's of hardware configurations. All the way from the smaller cards up to the biggest and baddest. .One guy who has 4 titan blacks has the same problem. It doesn't matter if its 8 gb of mem or 32gb, or the best Intel CPU for gaming that money can buy. It does not matter if the game is on a mechanical drive or if its on a SSD. The game needs to be fixed. Hopefully it can be without a rewrite of the engine "that isn't going to happen". I am really shocked they released this game for sale before it was ready. Wait for a patch and hope it works.
    Share this post

  7. #7

    Same here

    Almost exact same setup sans ssd. I7 4770k, sabertooth z87, 16gb corsair vengeance pro and an 780 ti sc acx. Game is unplayable for me. Stutters so bad at any settings especially while driving. I get random hiccups and before I know it I'm crashing into all kinds of stuff on the road. Kinda glad it's not just me and very disappointed / pi**ed at the same time.
    Share this post

  8. #8
    Moon920's Avatar Member
    Join Date
    Jun 2014
    Location
    Green Bay, WI
    Posts
    87
    I originally had pretty bad driving stutter with my 770 SC, I "fixed" it by doing all of the fixes I found on Reddit and this Forum. The fix that stands out to me as making the biggest difference was when I changed a few things in my gamerprofile.xml file, disabling page file check and I went through this,
    http://www.geforce.com/whats-new/gui...tweaking-guide


    I recorded this over the weekend, Medium/High settings at 1920x1080, hardly any stutter, decent framerate.

    Share this post

  9. #9
    Tirshek's Avatar Banned
    Join Date
    Jul 2014
    Posts
    85
    Originally Posted by Moon920 Go to original post
    I originally had pretty bad driving stutter with my 770 SC, I "fixed" it by doing all of the fixes I found on Reddit and this Forum. The fix that stands out to me as making the biggest difference was when I changed a few things in my gamerprofile.xml file, disabling page file check and I went through this,
    http://www.geforce.com/whats-new/gui...tweaking-guide


    I recorded this over the weekend, Medium/High settings at 1920x1080, hardly any stutter, decent framerate.


    As I think I've said to you in another post, these fixes are not working for everyone. I too have gone through and changed the settings in the log. I too have tried a shortcut with -disablepagefilecheck. All the fixes from here, and I think some similar ones from before I found that as well. Before trying those fixes linked I went through support rigamarole which included updating windows files, deleting temp files, reinstalling the newest nvidia driver, trying from a clean boot to see if the game would run.

    Tried applying these fixes. then reinstalling the game. Then applying the fixes again.

    Users on older cards seem to be better off.

    Seems my EVGA 780 ti is just a bit too new. Anyone playing fine on a 780 ti? I have yet to find someone. The guy in the video i linked is on a 780.

    https://www.youtube.com/watch?v=hhU8au9STIg

    Also found this quote pretty funny from the link you provided.

    Watch Dogs PC-Exclusive Graphics Enhancements

    Playing Watch Dogs on a geared-up PC grants you access to improved features and effects that the newest consoles are incapable of rendering. These include superior level of detail options for distant views, superior textures, models, water effects, reflections, vegetation, terrain, geometry, shadows, shaders, depth of field effects, and visual effects, to name but a few examples.

    hehe maybe in a few months that will be true after the modders finish enabling everything they disabled.
    Share this post

  10. #10
    Moon920's Avatar Member
    Join Date
    Jun 2014
    Location
    Green Bay, WI
    Posts
    87
    Originally Posted by Tirshek Go to original post
    As I think I've said to you in another post, these fixes are not working for everyone.
    Don't get your panties in a bunch Tirshek, I didn't realize you were a part of this thread. Like you said, "they are not working for everyone," but they are for some so there is no harm in mentioning it. I'm sorry you've been jumping through a lot of hoops. Keep trying, you'll come up with something.. or you'll find another game. "Soon" has come and gone and I haven't seen any mention of additional patches.

    Want to trade video cards? lol
    Share this post

Page 1 of 7 123 ... Last ►►