🛈 Announcement
Greetings! Watch Dogs forums are now archived and accessible in read-only mode, please go to the new platform to discuss the game
  1. #1

    NVIDIA High Definition Audio drivers causing massive FPS/stutter problems

    Found out about this thanks to this thread on the Steam Discussion boards http://steamcommunity.com/app/243470...=1401524323#p1 .

    Basically, for NVIDIA users, there is a massively widespread problem causing the NVIDIA HD sound drivers to decrease the performance of the game drastically. Typically with stutters and freeze spikes that last up to 2-8 seconds or so.

    Disabling these helps most people tremendously, according to that thread. However, the issue also seems to be with the game audio itself. Because disabling the NVIDIA drivers did not help me. Using the -nosound command for the .exe launch options did. (also suggested in the thread above)

    So this is something definitely specific to the game. Please forward this to the appropriate department, as it is clearly a very crippling issue.

    Thanks. And for those of you who are desperate for a fix and don't mind playing without sound; Either disable all NVIDIA HD Audio drivers via Device Manager, or add the -nosound command line at the end of the WD.exe target. I didn't do that, myself. As I have the Steam version. So I just set that command in the launch options instead. It's essentially the same thing, anyway.
    Share this post

  2. #2
    + 1

    Although I haven't tested the sound thing myself.
    Share this post

  3. #3
    The issue seems to be connected to the actual sound of WD. Since someone reported that they disabled sound (via launch options), but they have no NVIDIA card or audio driver to speak of. It still helped them, however.

    So it's not just NVIDIA specific.
    Share this post

  4. #4
    Tully__'s Avatar Global Moderator
    Join Date
    Nov 2003
    Posts
    17,367
    Some console users have experienced a similar improvement by disabling 5.1 / 7.1 surround and opting for Stereo settings instead. Have you tried this on PC?
    Share this post

  5. #5
    Originally Posted by Tully__ Go to original post
    Some console users have experienced a similar improvement by disabling 5.1 / 7.1 surround and opting for Stereo settings instead. Have you tried this on PC?
    I have not. I don't use surround sound, myself. Is this an audio option in-game that can be activated by accident, even without compatible surround sound setups? Or would this mean general windows surround sound settings?
    Share this post

  6. #6
    Originally Posted by Tully__ Go to original post
    Some console users have experienced a similar improvement by disabling 5.1 / 7.1 surround and opting for Stereo settings instead. Have you tried this on PC?
    I only have Stereo on my default device (Monitor) I tried plugging in my Headset which has 7.1, no change. But, this audio driver is the cause of all my issues. I can play with device disabled but who would want too?


    Sort it!
    Share this post

  7. #7
    Originally Posted by staff777 Go to original post
    I only have Stereo on my default device (Monitor) I tried plugging in my Headset which has 7.1, no change. But, this audio driver is the cause of all my issues. I can play with device disabled but who would want too?


    Sort it!
    Forced Audio to come out of Realtek HD through Headphone jack. No difference. Its an issue with the game not the audio devices.
    Share this post

  8. #8
    Can a mod add this to the "Known Issues" thread please?

    Thannks
    Share this post

  9. #9

    Originally Posted by staff777 Go to original post
    Can a mod add this to the "Known Issues" thread please?

    Thanks
    Umm, please?
    Share this post

  10. #10
    Hey, I'm the OP for the Steam thread.

    Thanks for posting this over here, I hope that Ubisoft can fix this issue soon
    Share this post