1. #21
    Originally Posted by Tomar777 Go to original post
    damn i didn't see that... there go my money for nothing... btw there are more games having the same issue with optimus... i think the one that shoud do something about it is Nvidia... if they care...
    well i am pretty sure its not game issue , but driver issue - try to spam NVIDIA support - they seems to ignore this issue and we might force them to say something official. This problem happens only on 64bit game executables so there must be some problem with 64bit games in NVIDIA's optimus laptop drivers!!
    Share this post

  2. #22
    In youtube I can see several videos of people running it on their laptops and also I've asked this to neighboring forums and some replied to me that they have no problems with their optimus / laptops.
    Share this post

  3. #23
    Originally Posted by alung777 Go to original post
    In youtube I can see several videos of people running it on their laptops and also I've asked this to neighboring forums and some replied to me that they have no problems with their optimus / laptops.
    well the issue happens only on Win7 as far as i know (at least I with Win7 have that problem and friend of mine with same laptop but Win doesn't)
    Share this post

  4. #24
    Actualy i have the same issue on Win 8.1 (Asus n550jk 850m mobile)

    Some observations:

    With latest nvidia drivers (337.88) I was not able to set gpu for any game profile (settings were always reverted when relaunching control panel), drivers 337.81 (beta) fixed that and I was able to set dedicated gpu for watch_dogs.exe (with help of nvidia inspector). And here I was able to observe something interesting: before launching game I double checked that game profile was setted to high performance. With game launched (uplay client offline and then closed) something is actively resetting watch dogs profile to "use global setting (integrated)".

    So not only ubisoft "forgot" to include optimus calls, they also actively disabling us to circumvent this setting

    I really hopes that Ubisoft will fix this issue, otherwise I don't think that I will ever consider to buy another Ubisoft product....
    Share this post

  5. #25
    Oh dear god Ubisoft, this doesn't sound like a difficult problem to fix. Please just let me play your expensive, broken game.
    Share this post

  6. #26
    bumpin this thread
    Share this post

  7. #27
    I still think its more likely issue of Nvidia's Optimus drivers rather than Ubisofts fault. I recently bought Van Helsing RPG game and have same problem with its x64 exe ;-(
    try to post avout the issue on Nvidia forums: https://forums.geforce.com/default/t...th-my-gtx660m/ and post about an issue to nvidia twitter https://twitter.com/nvidiacc
    Share this post

  8. #28
    I have been able to fix this issue.

    Necessary steps are following:

    1) Uninstall nvidia related apps (driver, geforce experience, physix).
    2) Probably you will still have some traces left, so download Display Drivers Uninstaller, reboot in safe mode, and uninstall all nvidia drivers.
    3) Install latest drivers from nvidia. Custom Install, DO NOT install geforce experience.
    4) Reboot
    5) Go in nvidia control panel, and add watchdogs exe (in my case it's located in D:\Games\Steam\SteamApps\common\Watch_Dogs\bin). If everything is ok you should see something like this.


    If Graphic Processor is not set on nvidia gpu, try to force it on it.
    6) Run the game and check if works.
    Share this post

  9. #29
    @Alekcand3r : doesnt work for me on Win 7 (This method works only for 32bit games for me) , tried to force it with afterburner asweell and it still runs intel GPU even though its forced to Nvidia GPU through aafter burned and control panel
    Share this post

  10. #30
    I just followed all of those steps. No luck. Game still runs on the Integrated GPU
    Share this post