1. #131
    Originally Posted by metalfenix_666 Go to original post
    did you create the shortcut correctly? you should create it the watch_dogs.exe file (just navigate to your watch_dogs folder/bin). If that's so...maybe your stuttering issue is not related to sound.
    Yes I created the shortcut from the .exe in the watch dogs folder. Like so "C:\Program Files (x86)\Ubisoft\Ubisoft Game Launcher\games\Watch_Dogs\bin\watch_dogs.exe" -nosound
    Share this post

  2. #132

    Originally Posted by gr00vedaddy13 Go to original post
    you'll notice that if you restart and then load the game, you'll get something like 30 - 45 minutes of no stutter. Not sure if it's a gradual thing, or if it happens when you fast-travel or what. I haven't really paid that much attention. But, in my case, quitting to desktop and then re-running the game has no effect, unless i restart. Definitely strange. Doesn't happen with any other programs or games, just this one. I suspect that some resource isn't being released. At first, i thought it may have been related to the pagefile, but i have my doubts. I've seen posts with people that have disabled their pagefiles and still have the issue. Also, if memory serves, windows by default does not clear the pagefile on shutdown or restart.

    The only thing i can think of that would stay resident after quitting would be like a cache of some sort. Perhaps a dll? Windows does have a registry option to unload dlls for programs that aren't actively using them, but i believe it's only for explorer extensions. What really hampers someone finding a solution is there's really not a whole lot to experiment with since everything's stored in those .dat files. Well, you've got the settings xml, but nothing else. No console commands or any other switches other than the "disablepagefilecheck". I'm sure they're doing this to protect their product, but it's the difference between ubi's programers investigating the problem, and them + us investigating it.
    you earned my respect, you just said everything
    Share this post

  3. #133
    Originally Posted by spikerules2 Go to original post
    Yes I created the shortcut from the .exe in the watch dogs folder. Like so "C:\Program Files (x86)\Ubisoft\Ubisoft Game Launcher\games\Watch_Dogs\bin\watch_dogs.exe" -nosound
    Yeah, the stutter stops for 15 min of gameplay, and it gradually returns, like it ever does.
    Dissembling the audio, in my conception, is just a placebo effect.
    Share this post

  4. #134
    metalfenix_666's Avatar Member
    Join Date
    May 2014
    Location
    Caracas, Vzla
    Posts
    73
    Originally Posted by Kokebot Go to original post
    Yeah, the stutter stops for 15 min of gameplay, and it gradually returns, like it ever does.
    Dissembling the audio, in my conception, is just a placebo effect.
    In my case the stuttering begins as soon as I get out of the safehouse, but disabling the sound eliminate the stuttering for me, and I've played for one and a half hour with no stuttering. Keep in mind that all my settings are in low/off.
    Share this post

  5. #135
    tlr_87's Avatar Junior Member
    Join Date
    Jan 2010
    Posts
    10
    Originally Posted by gr00vedaddy13 Go to original post
    You'll notice that if you restart and then load the game, you'll get something like 30 - 45 minutes of no stutter. Not sure if it's a gradual thing, or if it happens when you fast-travel or what. I haven't really paid that much attention. But, in my case, quitting to desktop and then re-running the game has no effect, unless I restart. Definitely strange. Doesn't happen with any other programs or games, just this one. I suspect that some resource isn't being released. At first, I thought it may have been related to the pagefile, but I have my doubts. I've seen posts with people that have disabled their pagefiles and still have the issue. Also, if memory serves, windows by default does not clear the pagefile on shutdown or restart.

    The only thing I can think of that would stay resident after quitting would be like a cache of some sort. Perhaps a dll? Windows does have a registry option to unload dlls for programs that aren't actively using them, but I believe it's only for explorer extensions. What really hampers someone finding a solution is there's really not a whole lot to experiment with since everything's stored in those .dat files. Well, you've got the settings xml, but nothing else. No console commands or any other switches other than the "disablepagefilecheck". I'm sure they're doing this to protect their product, but it's the difference between UBI's programers investigating the problem, and them + us investigating it.
    Well said.


    Conversely look at Bethesda Game Studios and how they open up everything and fixes come from the community. Skyrim was not the best optimized game to start with but there were more options to mitigate the performance issues. Also look at how that game has benefited by having a modding community.


    I do hope a patch comes soon.
    Share this post

  6. #136
    tlr_87's Avatar Junior Member
    Join Date
    Jan 2010
    Posts
    10
    This video is the only fix which has come close to fixing my frame rate issues. I still have frame rate hitches but it has just lessened the severity of it and does not fully fix the issue.


    https://www.youtube.com/watch?v=yIxupy0DgGEx=1
    Share this post

  7. #137
    Originally Posted by tlr_87 Go to original post
    This video is the only fix which has come close to fixing my frame rate issues. I still have frame rate hitches but it has just lessened the severity of it and does not fully fix the issue.


    https://www.youtube.com/watch?v=yIxupy0DgGEx=1

    I will try that solution, because the stuttering at my site at moment is very annoying. You can see a video driving fast in cars - https://www.youtube.com/watch?v=nQuv...ure=youtu.be&a

    A lot of stuttering. Do not happen always, but most of the time it is there.
    Share this post

  8. #138
    Everyone should try these launch options, what do you have to lose
    If you do not have a watchdogs shortcut you can modify, like the one of uplay just make a shortcut and modify. Just remember, if you want to launch your modified shortcut, Open Uplay first before clicking the shortcut otherwise it opens uplay alone. It doesn't work if you open it via uplay.
    -disablepagefilecheck +m_rawinput 1

    Set everything to high, water can be on ultra. Set textures to high as well.
    Turning off vsync completely via Nvidia control panel, okay you get screen tearing, but better frames overall.
    1 pre rendered frames
    Share this post

  9. #139
    I did the following:

    Set 'Shadow Cache' off in the NVIDIA control panel, see youtube above.
    Add -nopagefilecheck to a watchdogs.exe shortcut.
    placed my windows page file and WD install on my SDD

    I own a Gforce780ti. Can run textures on ultra, AA on Temporal SMAA. All effects maxed out on 1080p. It's not SUPERsmooth, but playable...for about half an hour, then you have to restart due to what I assume is a memory leak of some sorts.

    The game IS broken. Given the fact you need to tweak this ammount of stuff to get it running on a 600 USD GPU is absurd, especially since Watchdogs came bundled with the card and Nvidia is marketing the crap out of it..
    Share this post

  10. #140
    metalfenix_666's Avatar Member
    Join Date
    May 2014
    Location
    Caracas, Vzla
    Posts
    73
    Originally Posted by Fir3wulf Go to original post
    Everyone should try these launch options, what do you have to lose
    If you do not have a watchdogs shortcut you can modify, like the one of uplay just make a shortcut and modify. Just remember, if you want to launch your modified shortcut, Open Uplay first before clicking the shortcut otherwise it opens uplay alone. It doesn't work if you open it via uplay.
    -disablepagefilecheck +m_rawinput 1

    Set everything to high, water can be on ultra. Set textures to high as well.
    Turning off vsync completely via Nvidia control panel, okay you get screen tearing, but better frames overall.
    1 pre rendered frames
    tried, but it didn't work for me. Thanx for the tip anyway, mate.
    Share this post