🛈 Announcement
Greetings! Watch Dogs forums are now archived and accessible in read-only mode, please go to the new platform to discuss the game
  1. #361
    Intel core I5 650 3.2ghz
    Win 7 64 bit
    ATI Radeon 6870 HD video card
    12gb system memory
    1.5Tb sata II with 1.3Tb free space
    850watt pwr supply
    play all my games using 1920 x 1080 resolution

    My rig is three years old and only problem I have had so far was the freezing on loading screen or a crash after playing a few minutes,...I downloaded the 14.4 AMD drivers and game worked fine,..no issues since
    Share this post

  2. #362
    this sucks still not play it yet wtf i have window 7 you dumb *** game jesus
    Share this post

  3. #363
    Originally Posted by Zenwar2014 Go to original post
    Intel core I5 650 3.2ghz
    Win 7 64 bit
    ATI Radeon 6870 HD video card
    12gb system memory
    1.5Tb sata II with 1.3Tb free space
    850watt pwr supply
    play all my games using 1920 x 1080 resolution

    My rig is three years old and there is always a game that comes along and just wrecks your system and gives you a wake up call to buy a new one,...this game does that to mine. I cannot play this game! I meet minimum specs,..I can play online games like Elder Scrolls Online and Marvel Heroes Online very high or Ultra settings no issues and first person shooters like Wolfenstein New Order on high settings with lag,... but this game ...wont get passed loading screen or if I do it crashes after a few minutes of playing. I really want to play this game,..but I might be forced to buy a PS4 to play it
    Its not your rig. I cannot play this game at an enjoyable experience.

    My Rig:
    Intel Core i5 3470
    Nvidia Geforce GTX 760 2GB thats oc'ed
    8 GB system ram
    2x Seagate 750GB SSHD in RAID 0

    The game's engine is called Disrupt because it disrupts and rapes my system. I get this consist freeze frame bull**** and when the game wants to run ok I get frame freezing. I just reinstalled Windows 7 three weeks ago because of some issues I had with my administrative tools.

    Ubisoft, your game has poor optimization and i can point out a few flaws
    1) thread optimization. This game is poor on my quad core. One core is being used to the max and all of the other ones are basically under 20% load.
    2) GPU resources. My 760's usage is up and down. When I am not moving the usage go in between 10 and 90 and I still get frame skipping.
    3) make proper use of the page file. its there for a reason.
    Share this post

  4. #364
    Originally Posted by Stealth37Killer Go to original post
    3) make proper use of the page file. its there for a reason.
    I've actually found that flagging the executable to disable the page file, can mitigate some of the stuttering when driving. Not sure if it would be stable with 8GB of RAM, as I've got 16GB, but worth a shot.

    No question that the engine is pretty horribly optimized, however.
    Share this post

  5. #365
    Intel Core i7 4930K 3.4Ghz
    Win 8.1 64 Bit
    CROSSFIRE: 2 x ASUS R9 290X DCII OC
    16 GB system memory
    Game installed on a Samsung EVO SSD
    1500 Watt pwr supply
    1920 x 1080 resolution

    I should have about the double performance for Ultra settings. When I set the graphics to ultra settings with only FXAA I get on the street about 30 fps and a hardcore stuttering. Driving is impossible. When I switch all graphics to low I get about 70 fps and it looks like GTA 3. And it still stutters while driving. After trying to find a solution for this enormous performance problem I closed the game and googled. But after that I wasn't anymore able to start the game because it crashed every time at the screen with the saving information. I installed the newest graphics drivers and tried a lot of solutions I found on the internet. Nothing worked. Only option will be to try to reinstall the game JUST to be able to search for a solution so the game could be playable.

    My conclusion: This game doesn't even run properly on a 2400€ gaming PC. There aren't even words for how disappointed I am.

    EDIT: After shutting down crossfire it works again. With the same performance as before. Seems like it just didn't use the second graphics card at all at the beginning. This is just crazy and unacceptable.
    Share this post

  6. #366

    Works fine

    Quad 2 core, Q6600 at 3100mHz
    mobo asus P5K
    Nvidia GTX 750 TI OC
    6Gb memory.

    runs fine watch dogs on mediem
    Share this post

  7. #367
    Gtx 770 4gb
    I7 3770k@ 4.2 ghz
    16gb corsair vengeance pro
    Ssd install

    Nope does not run well
    Share this post

  8. #368
    My PC:
    i5-4670k Processor
    8GB Corsair Vengeance RAM
    GTX 760 graphics card
    Running on windows 7

    Game runs very well, all on 'high settings' with AA on highest at 1680x1050 res, wud say im running about 38 fps average
    Share this post

  9. #369
    i5 4670k
    8GB DDR3 1600
    ASUS GTX 660 (factory OC)
    Asus z87k mobo
    120GB Kingston SSD

    Runs great with everything at High with TSMAA and MHBAO.

    No crashes to desktop, very minor stutter only when steering while driving (no stutter in a straight line...). No bugs, online/offline all working well.
    Getting into Uplay was a pain on launch day, no issues since then.


    However, CHECK YOUR SYSTEMS folks!!!

    This weekend went to see a friend, who has a much better rig than me (i7 4770, 16GB RAM, gtx 780ti, SSD) and it was running dreadful for him.
    However his PC was a mess.
    Nearly 20 items running at startup, dozens of services he didn't need, few bits of adware/spyware. More money than sense.
    Spent half an hour cleaning it all down for him, removed a bunch of junk he didn't need and it ran same as mine, except on Ultra.

    Seriously, most gamers should stick to consoles... :
    Share this post

  10. #370

    Bullcrap

    I'm playing with an ASUS G74SX. Everything about this laptop is golden, sure it may be a couple of years old now, but it still kicks titanfall in 3D (not that I do that often), but I can play most games on high settings if not 3D. The only potential thing that I might have an issue would be my processor which is an i7 - 2670QM @ 2.20GHz. The fact that I can't play this game with at least minimal settings or even lowest settings is bullcrap.....It's almost like they set a frame limiter or something because anytime I move to fast or am in a car, the frames drop and it has an unbearable stutter, even with audio. I'm not going to say that this game is horrible, but I feel that it wasn't properly optimized for pc users. When I can play GTA, Assassin's Creed, Far Cry 3, Skyrim, and multiple MMO's perfectly on high details just mind boggles me. Hoping Ubisoft comes out with there said patch to fix this, but until then, I'm done. If anyone has any helpful tips or tricks to get this thing to work even decently on the lowest settings for me, let me know.

    EDIT: OH, and I have this game on a 500GB SSD, yet another mind boggling thought
    Share this post