1. #1

    Ambient Occlusion kills frame rate

    First off, WOW! I haven't played since the original beta released (on March 21st), and I you have been busy at optimizations.

    I could play maxed out on 1920x1080. But if I turned on to a triple screen resolution, at any graphical setting (including the lowest), it would go complete slo-mo. I can now play with a triple screen resolution (5900x1080)... and it's on "ultra" settings, with exception that I need to turn off Ambient Occlusion. With ambient occlusion turned on I go from silky smooth 60 frames per second (with zero drops) and drop down to it saying 30 frames per second but everything in slo-mo.

    I don't really care if you get it so I can play with this feature enabled... because it looks amazing as is... but it would be cool if you find out what the issue is (maybe nVidia specific).

    Specs: i5-3570k @ 3.4 Ghz, GTX 680 2GB (335.23, latest WHQL drivers from nVidia), 8 GB RAM.

    Cheers!
    Share this post

  2. #2
    sebastianaalton's Avatar Trials Developer
    Join Date
    Mar 2014
    Posts
    2,455
    We use super high quality MHBAO (multi-resolution horizon based ambient occlusion) algorithm. It looks awesome, but is quite demanding to the GPU. At your super high 5760x1080 resolution, I recommend that you disable the ambient occusion.
    Share this post

  3. #3
    I understand. Extremely happy to be able to play with correct triple screen rendering, great job to your entire team. Can't wait to get online with some multiplayer, that was my favorite feature in Evolution.
    Share this post

  4. #4
    Darn... had to turn down to the "High" default when I reached the Dust Storm (forget the actual name) level. Snow levels never had issue, nor the water effect ones, but this one killed the framerate. But I'm perfectly happy with "High" settings on triple screens... so awesome.
    Share this post