1. #1

    Far Cry 3 Map editor Rotating Camera Issues

    I'm having an issue trying to properly rotate my camera in the map editor. The w,s,a,d and shift seem to be the only controls keys that are functioning properly except for the logitech mouse that I am using. Whenever I try to rotate or pan the camera, it will look straight up or down. Panning the camera causes it to face the sky and makes it's irritatingly difficult to face the map. Does anyone know how to fix this issue with the editor?
     1 people found this helpful
    Share this post

  2. #2
    Have you tried holding the right mouse button? That's the general way of looking around. You can also hold the middle mouse button (scroll) to track around while maintaining camera direction. Otherwise you might wanna go to your Documents/My games/Far Cry 3 and tweak the mouse controls in your GamerProfileIGE.xml file. Mouse smoothing might be causing some issues there.
    Share this post

  3. #3

    Camera pan issues

    Originally Posted by Lovetuplay Go to original post
    I'm having an issue trying to properly rotate my camera in the map editor. The w,s,a,d and shift seem to be the only controls keys that are functioning properly except for the logitech mouse that I am using. Whenever I try to rotate or pan the camera, it will look straight up or down. Panning the camera causes it to face the sky and makes it's irritatingly difficult to face the map. Does anyone know how to fix this issue with the editor?
    I had the same problem, but it works now try going into your devices on control panel and selecting your mouse, then go into properties and then pointer options, in the motion bit uncheck Enhance pointer precision and apply. That worked for me good luck.
    Share this post

  4. #4

    Still not working

    Originally Posted by MarkNutt97 Go to original post
    I had the same problem, but it works now try going into your devices on control panel and selecting your mouse, then go into properties and then pointer options, in the motion bit uncheck Enhance pointer precision and apply. That worked for me good luck.



    I did that, and it worked for a while, but now it's doing it again, I checked the settings and it's still unchecked
    [/QUOTE]
    Share this post

  5. #5

    Mouse/Camera movement

    A
    Share this post

  6. #6

    Mouse camera movement fix

    I'm posting this so that if someone finds this thread after a desperate Google search like I have, they then hopefully have a point of reference. tl;dr at the bottom.

    I think that I might have found the solution for this particularly odd problem. First of all let me start by saying that this was done on Windows 10, so I can't guarantee that this works with earlier or later version of Windows.

    Anyhow, the problem with my system was that, like the people in this thread, the mouse would only rotate the camera in a very harsh movement almost like it looked to a random position as you only moved the mouse very slightly.

    So first I started testing with different mice, but that didn't do anything. I also disabled the touchpad of my laptop and only used the externally connected mouse, but this also didn't do anything. One strange thing however was that the touchpad didn't really have this strange issue, but this also isn't a great solution as I really don't want to design a map in first person with a touchpad only to work with.

    The next thing that I tried was testing it on my desktop with the same mouse as well as two mice connected at the same time to see if that would confuse the editor. This wasn't the case as that system ran just fine without any camera issues. What was different however was the scaling difference between my laptop and desktop, namely my laptop being at 125% and the desktop at 100%. So I finally had a new suspect. Could it be that the map editor didn't handle scaling very well? Because as it is known, old Windows applications most of the time don't handle scaling very well. And Far Cry 3 being from 2012 this could be a possibility. First it turned down the scaling to a 100% and this fixed the mouse issue completely, but I don't want to use my laptop at 100% just because Far Cry doesn't play nice with it. So luckily there is a nice option in the compatibility tab of the application properties. That being, 'override high DPI scaling behaviour.'. And after checking that checkbox, selecting from the drop-down menu underneath that checkbox 'Scaling performed by: Application'. This will give the Far Cry editor scaling that it can work with while I don't have to strain my eyes by looking at 100% scaling and instead using 125% scaling.

    TL;DR
    The issue has to do with scaling. Go to the folder that you have Far Cry 3 installed and then enter the folder named 'bin'. After that search for a application in there named 'FC3Editor' and right click it. Now go to properties and select the compatibility tab. In there check the checkbox named 'Override high DPI scaling behaviour.'. and from the drop-down menu below that make sure that it's set to 'Application'.

    This should now have fixed your mouse problems in the Far Cry 3 Editor. If not, then feel free to contact me here and maybe we'll find another solution.
    Share this post

  7. #7
    I think i have your answer to the mouse view problem in the editor.
    I TRIED EVERYTHING.

    . to fix this run the game not the editor ,
    go into options , mouse keyboard, and reduce the mouse look value. i ran the editor after the change and its good to go.
    Share this post