1. #1
    Zzzlol94's Avatar Member
    Join Date
    Mar 2014
    Location
    Norway
    Posts
    130

    Request: Faster menu loading [IMPROVED]

    All the menus load slowly. There's a delay of about 1 second every time you go in and out of menus. I know a part of it is to make it look good, but I'm pretty sure it's possible to make it look good WITH no delay. Some of the larger transitions, like changing from RIDE to GARAGE where the background moves, are fine, because you can't do a lot to speed that up without messing up the transition. But most of the more 'basic' menuing, like going back and forth in the settings, should be faster.

    The most important menu that should load quickly is when you're in a track. If that menu can load instantaneous or a LOT quicker, than what it does now, that would probably something most people would appreciate.
    Share this post

  2. #2
    Xhane's Avatar Player Experience Manager
    Join Date
    Oct 2009
    Posts
    428
    Hey Zzzlol94,

    After the last updates, can you let us know how this issue as evolved on your side?

    Cheers!
    Share this post

  3. #3
    Zzzlol94's Avatar Member
    Join Date
    Mar 2014
    Location
    Norway
    Posts
    130
    Right now, not sure how it was before, since I posted this a while ago and if there was a change, it wasn't clearly stated in the patch notes. Going out of menus is fairly quick. In Help & Options, entering submenus still takes a second, going out is instant. Still the one that's most important, when you're playing in a track, is still delayed by a slight amount.
    Share this post

  4. #4
    loading screen of the bikes and suits isnt fixed for pc(unless u mean consoles)
    It takes 15 to 20 sec to load bikes or suites.
    Share this post

  5. #5
    Originally Posted by Smilies2013 Go to original post
    loading screen of the bikes and suits isnt fixed for pc(unless u mean consoles)
    It takes 15 to 20 sec to load bikes or suites.
    Indeed.
    Another thing to point out are the streaming errors which create mad texture pop-in when switching scenes quickly.
    I mean come on - installed on an SSD, with 16 GB DDR3 RAM and 6 GB VRAM on the GPU...
    Share this post

  6. #6
    En0-'s Avatar Trials Developer
    Join Date
    Jun 2011
    Posts
    1,775
    Hello,

    We're working on a fix for the 15/20 seconds to load bikes and suites.
    For the texture popping, it was a choice between rendering and gameplay. To be able to retry instantly, we have to allow this texture popping (Sebastian explained in another thread). So, we could fix it, but we would have to synchronize the texture loading with the retry, that would damage the experience. That's why it is like that.

    Cheers,
    Share this post