1. #1

    Game seem sluggish

    Having frame rate issues game plays sluggish...I5 4670k 3.5...8 gig 2400 ram...Gtx 650sc 1gig vram...ssd. Max settings on high vsync on 30 frames plays in near slow motion. Low settings vsync off frames yo yo from 30 to 40s. had to drop res to 1600 by 1024 and play low no vsync to get 55 frames plays smooth tho. Do I need better GPU ?
    Share this post

  2. #2
    aondw's Avatar Junior Member
    Join Date
    Mar 2014
    Posts
    15
    I play on i3-3220 and HD 7870 with no problems, I don't know if the game is GPU heavy, but I think so, at least it's not CPU heavy.
    Regardless of the problems, I would definitely upgrade the gpu.

    The problem could be AA, as this is very vram heavy.

    As the graphics options in fusion are kind of ****ty, I can't say which AA it uses.
    Share this post

  3. #3

    SLI problems

    Experienced drastic loss of fps in-game. Inside areas were at 10-15 fps and outside area at about 5 fps. In other words unplayable. I tried changing all possible graphics settings from the settings menu but nothing helped. Switched off SLI in the NVIDIA controlpanel and tried again. Worked perfectly. I can now run the game with graphics setting maxed out. Just thought I should share it if anyone else experiences the same.


    System spec:
    2x GeForce GTX 650 Ti BOOST
    Windows 8.1 64-bit
    AMD FX(tm)-8350 at 4Ghz
    16384MB RAM
    240GB SSD
    DirectX 11
    Share this post

  4. #4
    Camzarcar's Avatar Senior Member
    Join Date
    Mar 2014
    Location
    Australia
    Posts
    612
    Originally Posted by Cavalieris Go to original post
    Experienced drastic loss of fps in-game. Inside areas were at 10-15 fps and outside area at about 5 fps. In other words unplayable. I tried changing all possible graphics settings from the settings menu but nothing helped. Switched off SLI in the NVIDIA controlpanel and tried again. Worked perfectly. I can now run the game with graphics setting maxed out. Just thought I should share it if anyone else experiences the same.


    System spec:
    2x GeForce GTX 650 Ti BOOST
    Windows 8.1 64-bit
    AMD FX(tm)-8350 at 4Ghz
    16384MB RAM
    240GB SSD
    DirectX 11
    I'm a computer noob, what's SLI? And how do you turn it off?
    Share this post

  5. #5
    Post deleted by Dam
    Share this post

  6. #6
    Blastergamer's Avatar Senior Member
    Join Date
    Mar 2014
    Location
    Rocking Trials Country
    Posts
    2,539
    Originally Posted by Camzarcar Go to original post
    I'm a computer noob, what's SLI? And how do you turn it off?
    SLI is a NVIDIA technology which allows you to have multiple SLI-supported graphics cards work together, which can be from 2-4 cards. Lower-end and older cards usually don't support SLI (check your GPU if that supports!), AND your motherboard has to support that too!

    You can turn SLI off in the Nvidia Control panel, which can also be accessed by clicking right mouse button on the desktop. If your hardware doesn't support SLI then there is no SLI options and availability.
    Share this post

  7. #7
    You're not the only one surprised with the framerate issues.

    I can run BF4 and all the big hitters on Ultra no problems. I fired this up after getting it today on Steam and it lags horribly. From my limited playtime it seems it's worst on outside areas. Some levels it runs smooth as silk on max settings (as it should) but some levels it really slows down to a crawl, then speeds up to normal framerates seemingly at random.

    Very strange?

    I'm more than willing to help the developers de-bug this if they need any information from me, let me know. This is a Beta after all!!
    Share this post

  8. #8
    sebastianaalton's Avatar Trials Developer
    Join Date
    Mar 2014
    Posts
    2,455
    If you have SLI/Crossfire (double graphics cards) in your computer, I recommend disabling SLI/Crossfire (from your display driver settings screen) until we get driver profiles from Nvidia/AMD to fix the multi-GPU problems. Disabling SLI/Crossfire solves the (~10) fps issue.
    Share this post

  9. #9

    Originally Posted by sebastianaalton Go to original post
    If you have SLI/Crossfire (double graphics cards) in your computer, I recommend disabling SLI/Crossfire (from your display driver settings screen) until we get driver profiles from Nvidia/AMD to fix the multi-GPU problems. Disabling SLI/Crossfire solves the (~10) fps issue.
    Is there a solution to this slowdown when it occurs with single GPU?

    [edit1] UPDATE I was downloading at full tilt in background - paused it and game runs fine now. However, I set it going again and game seems unaffected! Therefore can't be sure of the cause. (this was all alt-tab; I never restarted the game)

    [edit2] UPDATE It seems to be the alt-tabbing that fixes the slowdown. I went into the bike menu and it drops to ~15fps... alt-tab x2 and it's happy again???

    Core i5
    nVidia Gtx 770
    8GB Windows 7 64bit
    Share this post

  10. #10
    sebastianaalton's Avatar Trials Developer
    Join Date
    Mar 2014
    Posts
    2,455
    Anyone still having fps issues after the latest patch, or should I change this thread to [SOLVED]-status?
    Share this post