1. #11
    So i also had the early acces version and downloaded the rest yesterday all via steam. Today i finished Act 1 ( I got the achievement) But then i coudnt meet with Lev for the transfer to Act 2. After I finished Act 1 I went back to the city to sell some stuff and when I can back there is no way to speak with him. I redownloaded the game reinstalled it and made sure i used the Key. Still nothing. Hoping there is an anwser for this soon as I really like the game!
    Share this post

  2. #12

    I have already posted this on another thread, thought I might post it here as well.

    If you're stuck and can't get to the forge do the following:

    1. Go to where you installed the game (I bought it on Steam, so it would be C:\Program Files (x86)\Steam\SteamApps\common\Might & Magic X - Legacy)
    2. Go here: \Might and Magic X Legacy_Data\StreamingAssets\Dialog
    3. Open: LevDialog
    4. Delete, or comment, the 4 lines that look like this: condition xsi:type="PrivilegeUnlockedCondition" privilegeID="1001" failState="DISABLED". This is XML code and if you don't want to delete them you can comment them out like I did by adding [<!--] and [-->] (without the brackets) at the start and end of the line respectively.

    After that I opened the game, talked to Lev and was able to get to the forge.
    Share this post

  3. #13
    I've tried that, didnt work for me. And besides there should be a different way to make this work. One that doesnt involve me tinkering with the files imo,
    Share this post

  4. #14
    Also cannot access act 2 even after following the linked instructions. Steam is downloading 4gig, the install is 8750mb and i don't know if it matters but my game key is still marked as "Might & Magic X - Legacy Deluxe Early Access Game Key" The version number shown in the main menu is 1.3.1-4561

    EDIT: Uplay shows my game key under account information. I can't try and re-enter it in game because i get a connection error (the game and Uplay both have firewall access)
    Share this post

  5. #15
    Hello I to have problem with access act II
    I launch MMX legacy through uplay
    i try activate key in game and it say key already activated
    my game directory ( size on disk ) 8.47 GB (9,102,479,360 bytes)
    and i do all what you say in post 12
    Share this post

  6. #16
    Hey BleH1988

    As I understand right, you forgot to meet with Lev. Happened to me also. And when you go back to the castle, you visit the 2 Masters instead of going into the dungeon.
    You need to hit the LEAVE button in the right corner (not ESC), and you should get a warning: "Ar you sure you want to enter the dungeon?" And say Yes.
    If youhit only ESC, you will leave.
    Third floor, up-right in the jail you will find Lev.
    Share this post

  7. #17
    I just tried to activate the steam key inside the game (activated it on uplay only so far) but it tells me the key is already activated, so I hope it is my activation it counts not someone elses.

    My steam key also starts with 67P, I hope we didn't all get the same key
    Share this post

  8. #18

    Originally Posted by Maschine83 Go to original post
    When i add the key trough uplay it says that it is already in use. Adding it Ingame trough the extras menu it says that i cant contact the ubi-servers. My internet is a-ok, saving to cloud and connection to uplay works as intended. Dont know what else to do. Any help would be appreciated.
    Same here. Have you solved the problem?
    FYI I bought the Deluxe Edition directly from UbiSoft. So no Steam here.
    It's very frustrating that this isn't working.
    Share this post

  9. #19
    It's frustrating like hell
    I have steam early-access deluxe edition. After premiere i delete all old game files and install a official release.
    I can't play act 2, and i can't redeem code form game menu becouse i have connection error.
    I shout down my firewall and antivirus, uplay don't show any connection issues.
    Share this post

  10. #20
    I also got the problem that the dialog with Lev is grey out. I downloaded the game via uplay. No Early Access was installed. And the key in Uplay is a different one as in the box. And in the game it says: Cannot connect. But Uplay can connect.
    Hope this will be repaired soon.
    Share this post