🛈 Announcement
Greetings! Assassin's Creed forums are now archived and accessible in read-only mode, please go to the new platform to discuss the game.
  1. #11
    andynaruto10's Avatar Senior Member
    Join Date
    Dec 2010
    Location
    Romania
    Posts
    594
    Originally Posted by puci11 Go to original post
    Hi.
    I have the same problem. Could anyone help us and upload this file ("40.spool"). We don't want to play another 20 or more hours for only making achievements, because uplay can't synchronize them. I have some achievements in uplay but most of them disappear and I don't have this file after reinstalling windows. Could you explain how part of them are saved without this file and the rest has gone?



    Could you upload this file "40.spool"? I will try if it works when I copy that into ubi folder. I would be appreciated if you could.
    I think the file is embed to the specific account, but you can try it and see if it works.
    https://docs.google.com/file/d/0B3LG...JPbGRVdGc/edit
    Share this post

  2. #12
    puci11's Avatar Junior Member
    Join Date
    Feb 2014
    Posts
    29
    Originally Posted by andynaruto10 Go to original post
    I think the file is embed to the specific account, but you can try it and see if it works.
    https://drive.google.com/file/d/0B3L...it?usp=sharing
    It seems you were right. I am trying to recover my file, because I installed Windows on my new SSD and only format HDD so there is really big chance to succeed. Also I think I have achievements that I got when I was playing few days after the game was released, because they don't have date next to them.
    Thanks for help anyway. Maybe it will work for anyone. It's Uplay
    Share this post

  3. #13
    puci11's Avatar Junior Member
    Join Date
    Feb 2014
    Posts
    29
    Ok. Got it with EASEUS Data Recovery Wizard. My spool file is named "59.spool". I think there is the difference because I have steam+uplay version and I have other number in spool but saves are in folder named "40".
    Here is link for my .spool file:
    https://docs.google.com/file/d/0B6Bk...jkxS0UyYkNhaG8

    Maybe it will work for someone.
    Share this post

  4. #14
    andynaruto10's Avatar Senior Member
    Join Date
    Dec 2010
    Location
    Romania
    Posts
    594
    59 is another game. I'm sure of that. Check C:\Program Files (x86)\Ubisoft\Ubisoft Game Launcher\data\59 and open uplay_install.state with Notepad and at the end of the line it should say the game.
    Share this post

  5. #15
    puci11's Avatar Junior Member
    Join Date
    Feb 2014
    Posts
    29
    Originally Posted by andynaruto10 Go to original post
    59 is another game. I'm sure of that. Check C:\Program Files (x86)\Ubisoft\Ubisoft Game Launcher\data\59 and open uplay_install.state with Notepad and at the end of the line it should say the game.
    This is AC Revelations.
    http://gameshunt.pl/gry-podpinane-do-uplay/
    Site is in polish but you can just check list of games.
    It is on that list: 40 uplay version and 59 steam version. In my case saves are under 40 and achievements under 59. Most important is that is working

    Edit: btw. I don't have the any folder named 59. I have only ACR (40/59), AC3 (54) and AC3L (625). No other game installed.
    Share this post

  6. #16
    andynaruto10's Avatar Senior Member
    Join Date
    Dec 2010
    Location
    Romania
    Posts
    594
    Originally Posted by puci11 Go to original post
    This is AC Revelations.
    http://gameshunt.pl/gry-podpinane-do-uplay/
    Site is in polish but you can just check list of games.
    It is on that list: 40 uplay version and 59 steam version. In my case saves are under 40 and achievements under 59. Most important is that is working

    Edit: btw. I don't have the any folder named 59. I have only ACR (40/59), AC3 (54) and AC3L (625). No other game installed.
    Oh, okay, my mistake. Also, thanks for that link with the Uplay IDs.
    Share this post

  7. #17
    Hi I have a similar problem.
    I noticed on assassinsnetwork.ubi.com that i did not have all achievements unlocked for revelations and brotherhood only some of them
    I launched revelations and noticed there was a 93% or 96% save which was downloaded from cloud (only thing left was to finish sequence 9) which i was pretty sure i finished back in 2012(i know i had all the achievements).

    So after trying to find out what happened i accidently deleted this save which has led to me to play the game all over again. Now i have a 100% save but i still miss some achievements (mainly lost archive ones and the Sage one where you have to get all the books+finish sequense 6 and 7). After finishing the game the achievements for finishing sequence 9 and 100% synch unclocked for me(besides these two no other achievement popped up).

    The ingame stats show every achievement as get. When i looked at assassinsnetwork it showed 48/48 but when i looked into uplay i still miss some. Tried to replay the sequences 6 and 7 for a few times as hinted by support but still no luck. And currently i do not have access to the computer i played it on so i cant check the spool files. any other suggestions?

    and this for brotherhood too. network shows not all achievements unlocked (although the 100% synch is unlocked) and ingame stats show that everything is complete. tried to replay some sequences but still nothing.
    Share this post

  8. #18
    Luckily, I had the 40. spool file backed up on a separate computer. The achievements for the main game are back the way they were. But, the lost archive achievements still aren't unlocking.
    Share this post

  9. #19
    Alright so, I tried pasting the spool file back in my computer. All the achievements were restored with the exception of the lost archive achievements. Usually it's 38 of 45 achievements completed. I also went into the save games folder in ubisoft game launcher and added the .deleted extension on the files in the folder. I did it while the game was running. I got this method from other forums on the ubisoft website. For good measure, I reinstalled uplay and ac revelations. I put the spool file back in after doing these things. I played through the lost archive again and managed to earn all the achievements both ingame and through the uplay PC client. All the achievements were completed 45 of 45. However the in game achievements for the main game were incomplete. I didn't think anything of this. Then I noticed after earning some achievements again, it started unlocking for both the uplay PC client and in game. I exited the game and saw that all my achievements were locked again 0 of 45. After rebooting uplay, there were 12 of 45 achievements unlocked. The same from before I pasted the spool file in my computer. So this just seemed to act as a temporary solution to the problem.

    I finally decided to get on the phone and call ubisoft tech support. They told me the only thing they can do is forward the issue to their development team.
    I asked if this possibly could be fixed in a future uplay update. I was told it would seem likely they might. I also went as far as to tell them, I never had achievement issues with the origin pc client or the steam pc client. So hopefully the uplay devs will fix this.

    So in regards to the spool file and adding the .deleted extension to the files in the save games folder, did I miss a step? If I did, let me know.
    Share this post

  10. #20
    Hi all,
    I had similar problems and I want to share with you a way I've found to sole the problem, at least for me.

    Background: I have the Steam version of Assassin's Creed Revelations, I completed every Single Player achievement (Lost Archive DLC included) and in game I have all the achievement as "Done".
    Going to Ubisoft Game Launcher client, 3 achievements were missing, and in particular "Complete Sequence 1" "Complete Sequence 2" and "Kill 50 enemies with hidden blades".

    This is what I tried:

    - I tried replaying the sequences I missed on Ubisoft Game Launcher, but as the achievements are "Profile Wide" they were already done in game, and so no achievement was sent to Ubi server.
    - I tried to remove the spool file as adviced before, but the Cloud system downloaded it again, so no chance.

    This is what I did:

    1) To be sure, I backed up the following:
    file C:\Users\<Profile>\AppData\Local\Ubisoft Game Launcher\spool\<Unique GUID>\59.spool
    folder C:\Program Files (x86)\Ubisoft\Ubisoft Game Launcher\savegames\<Unique GUID>\40

    2) Opened Ubisoft Game Launcher and went to "Offline Mode". Launcher restarts in offline mode.

    3) Removed all the folder C:\Program Files (x86)\Ubisoft\Ubisoft Game Launcher\savegames\<Unique GUID>\40
    I did not removed the 59.spool file, so that launcing the Ubisoft Game Launcher all the achievements I had were ticked.

    4) Launched the game (offline mode)

    5) The game starts with no profile configured, with all the 3 sessions empty.
    6) Created a new session, started session, checked at the achievements section, and they're all flagged as "not done".
    7) Exited the game, exited the launcher.

    8) Reloaded the launcher, now staying in online mode.

    9) Launched the game.
    The Could Management warns that the local savegames are not syncronized with cloud ones.
    I selected to use the local savegames, loosing the cloud ones.

    10) Reloaded the session created before, in offline mode, Reached the end of sequence 1, the achievement ticked in game and ticked on Ubi servers.
    The already done achievements on Ubi launcher were not erased and the missing achievement was added to the list.

    Now I'm here, I'll finish this evening sequence 2 and redo the 50 kills, so that all the achievements will be present online.

    After finishing all the missing ones, I'll restore the savegame folder with my backed up one, hoping the Cloud Management will not overwrite them.
    If the Cloud Management will overwrite them, I'll try to start with my previous savegame in offline mode, do "something" in game so that the savegame are updated locally, and reloading the game in online mode I think the Cloud Management will warn me again that local savegames are not syncronized with cloud.
    I'll use again local savegames and I think (hope) all will be ok.

    I never touched the .spool file, because I think it's the core for the achievements archive.

    I hope my experience will be usefull for someone else in my condition, or similar.
    Regards.
     2 people found this helpful
    Share this post