1. #1

    Extremely laggy on PC!

    Hi, I have all of the other Assassin's Creed games on my PC, and they run really well, but this one is too laggy to play, even with everything lowered as much as possible!

    I am using a Mac, with Windows 8.1 through Bootcamp. I'm not sure what my specs are, but I can run the third game without any lag or problem with decent video and resolution. Is there anything I can do to fix this? It looks like a lot of people seem to be having this problem, as well.......
    Share this post

  2. #2
    Originally Posted by Genzashi Go to original post
    Hi, I have all of the other Assassin's Creed games on my PC, and they run really well, but this one is too laggy to play, even with everything lowered as much as possible!

    I am using a Mac, with Windows 8.1 through Bootcamp. I'm not sure what my specs are, but I can run the third game without any lag or problem with decent video and resolution. Is there anything I can do to fix this? It looks like a lot of people seem to be having this problem, as well.......
    Update you drivers and disable v sync. V-sync in this game will lock you @ 30fps if you drop 1 fps under 60.

    Btw nobody can help you if you dont know and cant post your specs... and you ll always have ****ty performances with bootcamp compared to equivalent Hardware on a PC
    Share this post

  3. #3
    strigoi1958's Avatar Senior Member
    Join Date
    Oct 2010
    Location
    Norfolk UK
    Posts
    4,456
    The game is incredible and running brilliantly on my pc but my settings are all high not ultra except godrays are low.
    GTX670 2GB, Intel i5 3570k, ASUS P8Z77-V LX, 8GB kingston DDR3 KHX1600, BENQ GL2450T, Windows 7 64 bit
    and I'm using 314.22 the best driver Nvidia make to date.
    NOTHING IS OVERCLOCKED ON MY SYSTEM CPU runs at 3.4
    Share this post

  4. #4
    Originally Posted by loucmachine2 Go to original post
    Update you drivers and disable v sync. V-sync in this game will lock you @ 30fps if you drop 1 fps under 60.

    Btw nobody can help you if you dont know and cant post your specs... and you ll always have ****ty performances with bootcamp compared to equivalent Hardware on a PC
    I have a GTX 780, intel i7 3930k, 16gb of ram, win8.1 and i am having the same problem, stupid amounts of lag, i have the updated drivers and ive lowered the settings. i can play just about all the other games that have come out recently on max settings: Ghost, BF4, Batman

    Ive changed the compatability settings and tried both 7 and 8, uninstalled and reinstalled, even moved it to my solid state drive where my OS is. im running out of idea... so any idea's... and dont say its my hardware cause i know its not.
    Share this post

  5. #5
    Originally Posted by pladpenguin00 Go to original post
    I have a GTX 780, intel i7 3930k, 16gb of ram, win8.1 and i am having the same problem, stupid amounts of lag, i have the updated drivers and ive lowered the settings. i can play just about all the other games that have come out recently on max settings: Ghost, BF4, Batman

    Ive changed the compatability settings and tried both 7 and 8, uninstalled and reinstalled, even moved it to my solid state drive where my OS is. im running out of idea... so any idea's... and dont say its my hardware cause i know its not.
    TURN OFF THE V SYNC IT LOCK YOU AT 30 FPS

    Jeez read what i wrote !
    Share this post

  6. #6
    Originally Posted by loucmachine2 Go to original post
    TURN OFF THE V SYNC IT LOCK YOU AT 30 FPS

    Jeez read what i wrote !
    READ WHAT I WROTE what part of lowered setting does not make sense. V sync is off . still lag...
    Share this post

  7. #7
    Originally Posted by pladpenguin00 Go to original post
    READ WHAT I WROTE what part of lowered setting does not make sense. V sync is off . still lag...
    Then something is wrong cuz my 780 has no issue on this game maxed out...
    Is you gpu set to ''prefer maximum performance''?
    Share this post

  8. #8
    If i am looking in the correct place ive tried running it with max quality and max performance in the Nvidia control panel. If im looking in the wrong place directions would be nice. and the more and more time i spend trying to fix it i am not sure if it is a graphics problem. cause like i said i can run any other game on the highest settings with ease. AC4 seems to be almost freezing for a second to a couple seconds. its only using up 20% of my cpu and 30%of my ram and the system temp is only going up 8-10C which is normal.
    ive uninstalled it and re installed it too
    Share this post

  9. #9
    Lou is a ****en *******. Probably works for ubi
    Share this post

  10. #10
    ****en *******
    Share this post