1. #1

    Leap of Faith kills me everytime

    So I just recently started getting the itch to play the original Assassin's Creed game (AC1) and EVERYTIME I perform a leap of faith, i end up landing on top of the pile of hay and it kills me instead of allowing me to fall safely and not die.

    Is there a fix for this somewhere that I dont know about? Ive tried searching the internet but no one seems to have this issue.
    Share this post

  2. #2
    Ferrith's Avatar Senior Member
    Join Date
    Dec 2011
    Posts
    911
    What you experience is a very rare bug, and I'm afraid I haven't the slightest idea how you can get rid of it.

    Edit: Perhaps starting a new game could possibly fix it?
    Share this post

  3. #3
    Originally Posted by Ferrith Go to original post
    What you experience is a very rare bug, and I'm afraid I haven't the slightest idea how you can get rid of it.

    Edit: Perhaps starting a new game could possibly fix it?
    Problem is, i started it as a new game. Freshly installed.
    Share this post

  4. #4
    Ferrith's Avatar Senior Member
    Join Date
    Dec 2011
    Posts
    911
    There is no mention of this bug, but there was a patch for the game and it might fix your game. If you haven't it installed you can download it here:
    http://www.ubi.com/US/Downloads/Info.aspx?dlId=2507
    Share this post

  5. #5
    Anykeyer's Avatar Senior Member
    Join Date
    Dec 2009
    Posts
    4,561
    Try enabling vsync, it fixes many issues in this game.
     2 people found this helpful
    Share this post

  6. #6
    Vsync is a very good idea but also if you have intel i3/i5/i7 cpu with hyperthreading support disable it, if this will not help revert HT back to enabled.
    Share this post

  7. #7
    Originally Posted by Anykeyer Go to original post
    Try enabling vsync, it fixes many issues in this game.
    This fixed it for me, thanks!
    Share this post