1. #1

    Possible blackscreen / slow loading / laggy game FIX

    Hello all,

    normally I don't do this, but after reading up on 10.000 posts on a possible fixes, I thought I'd post mine.

    So these were my "bugs":
    - Starting the game would take ages. 5 minute splash screen, followed by a 5 minute black screen;
    - After the intromovie thing, 5 minute loading time (no black screen);
    - At game menu, the hero was laggy and background as well;
    - Pressing a option (campaign, multiplayer.....) would take ages;
    - Loading up for a game took long as well;
    - Finally in the game, it lagged like hell (not fun to play imo).

    So anyway, I got all of them fixed. I found out that Heroes VI didn't go well with multiple CPU's. So I set the affinity to 1 CPU and voila. It did the trick!
    (I also disabled thread-optimization (literally translated from Dutch) in NVidea). Make sure you're administrator to change the affinity!

    Hopefully this helps some players out there. Let me know if it does!


    Btw! If u don't like to set the affinity everytime u boot the game, use this as ur shortcut:
    C:\Windows\System32\cmd.exe /C start "runhigh" /high /affinity 01 "D:\Games\Might & Magic Heroes VI\Might & Magic Heroes VI.exe"

    Ofcourse u need to change the "D:\Games\Might & Magic Heroes VI" to your own path!
    Share this post

  2. #2
    Ubi-MoshiMoshi's Avatar Community Representative
    Join Date
    Nov 2011
    Location
    EMEA CRC
    Posts
    21,145
    Thank you for posting this, hopefully it will help others.
    Share this post

  3. #3
    I have another saves when I will be launch by uplay://launch/ and another saves if I use by local path. How to add shortcut by uplay launch?
    Share this post

  4. #4
    Ubi-Viral's Avatar Ubisoft Support Staff
    Join Date
    Oct 2015
    Posts
    3,163
    Originally Posted by Smerfiaczek91 Go to original post
    I have another saves when I will be launch by uplay://launch/ and another saves if I use by local path. How to add shortcut by uplay launch?
    Hi there.

    Having reviewed your query, in order to provide better support, I would like to request some more information from you.

    Please provide details and screenshots of any error message or code you may have received, and which steps you have already taken to remedy this issue. The more information you can give regarding your experience, the better equipped I am to assist you.

    Thank you.
    Share this post