1. #1

    Odd Graphics Glitch

    Hi All,

    I'm seeing on odd graphics glitch when playing with my laptop's Geforce 650m GT (see picture). Note the light blue box in the middle of the screen. These boxes most often show up over occluded structures (i.e. in the location the building would be if a wall weren't in its way). This doesn't happen when playing with the integrated Intel HD 4000 card, but that one gives much worse performance (duhh). Note that I'm using DX11. I tried switching to DX9 to see if it would fix the problem but the game started to get a mad startup crash (at startup it flickers back and forth between a black screen and the desktop, I have no control, and have to shut down the computer). Still trying to figure that one out, but if anyone has any ideas why the blue boxes would be appearing, I'd appreciate the help.

    Share this post

  2. #2
    Verify the cache if this is the steam version, that's one of the symptoms of the 50 invalid files bug.
    Share this post

  3. #3
    It's from UPlay. I figured re-downloading the game should have the same effect so I'm trying that.
    Share this post

  4. #4
    No dice. Redownloaded game. Even verified the installer files, but it made no difference. All files verified, and the issue is still there.
    Share this post

  5. #5
    Mr_Shade's Avatar Senior Community Manager
    Join Date
    Nov 2009
    Location
    EMEA CRC
    Posts
    21,532
    Hi there,

    It maybe an issue due to your graphics card - the 640 M is a mobile version - which is not officially supported by the game - it may owrk - but may suffer from issues.

    Laptop versions of GFX cards don't always perform the same as the desktop counterparts - drivers can vary - so you should try using slightly older versions - if you are upto date - and see if that corrects the issue: laptop cards are not officially supported by the game, as per the requirements - however you should contact support and see if there are any solutions open to you.

    They will also look into if it could be another issue - so please talk to them directly.
    www.support.ubi.com
    Share this post

  6. #6
    My drivers are up to date. I don't understand why mobile GPUs wouldn't be officially supported. I also don't see why I should be having this issue in Blood Dragon even though Far Cry 3 runs flawlessly. Not to mention that the issue doesn't show up in two youtube videos, one running on the same GPU as mine and another running on a sister mobile GPU (630m).

    I will contact support. In the mean time, could you please send me a link or something mentioning that there is no support for mobile GPUs. I can't seem to find any official information on it.

    Edit: Never mind, found it buried in the support page for the game. I still call BS on not supporting laptop GPUs. Stop being lazy UBI, if you're going to release a game on the PC, DO. IT. RIGHT.
    Share this post

  7. #7
    Originally Posted by jariullah Go to original post
    Edit: Never mind, found it buried in the support page for the game. I still call BS on not supporting laptop GPUs. Stop being lazy UBI, if you're going to release a game on the PC, DO. IT. RIGHT.
    may I ask what you found exactly and how you fixed it?
    Share this post

  8. #8
    Tully__'s Avatar Global Moderator
    Join Date
    Nov 2003
    Posts
    16,970
    Originally Posted by c0rtexe Go to original post
    may I ask what you found exactly and how you fixed it?
    I suspect it's this: https://support.ubi.com/en-gb/FAQ.as...0000000eVW8CAM and that he didn't fix it.
    Particularly note at the bottom this bit:
    * SUPPORTED VIDEO CARDS AT RELEASE

    ... a list of vid cards ...

    Laptop versions of these cards may work but are NOT supported. These chipsets are the only ones that will run this game.
    Share this post

  9. #9
    Originally Posted by Tully__ Go to original post
    I suspect it's this: https://support.ubi.com/en-gb/FAQ.as...0000000eVW8CAM and that he didn't fix it.
    I see, thank you for the reply. I am also suffering from this issue and it hinders my gameplay. I was also hoping for a resolve but seeing as my laptop isn't supported, I think I may reconsider further purchases of the far cry collection for the time being as I travel alot and have to play games on my laptop. Thank you again though.
    Share this post

  10. #10
    Originally Posted by c0rtexe Go to original post
    I see, thank you for the reply. I am also suffering from this issue and it hinders my gameplay. I was also hoping for a resolve but seeing as my laptop isn't supported, I think I may reconsider further purchases of the far cry collection for the time being as I travel alot and have to play games on my laptop. Thank you again though.
    So, I did eventually found a way to "fix" the problem. The problem only happens when I use DX11, so I decided to switch to DX9. The problem goes away when using DX9, but...

    I was unable to run the game with DX9 (see the mad crash mentioned earlier). If you switch to DX9 and start getting a startup crash, then the following fix should work.
    1. Run the game in DX11 mode and change it to Windowed. Then switch to DX9. Restart game.
    2. Get the WindowedBorderless tool (http://forums.steamgames.com/forums/....php?t=2675769).
    3. Switch the desktop resolution to the max you can handle in this game. Set the game resolution to be the same, and then make the window borderless using the tool given in 2.

    I would still like to see an actual fix for the DX11 problem, but I suspect UBI Support doesn't really care.
    Share this post