1. #1

    Anno 2070 - Can't connect to servers

    Ok, in case anybody from a support team actually sees this, I uninstalled and reinstalled Uplay. It doesn't show my copy of Anno 2070 in the Uplay games section, even though I bought it off Steam. How do I register this game through Uplay?
    Share this post

  2. #2
    Ubi-MoshiMoshi's Avatar Community Representative
    Join Date
    Nov 2011
    Location
    EMEA CRC
    Posts
    21,250
    Hi and welcome to the forums, have you opened the ports? http://ubisoft.custhelp.com/app/answ...ail/a_id/15851 you can also open a ticket with Technical Support, the link is in my signature.

    Steam games do not show in the Games tab in Uplay.

    Also as this is Steam are you launching from the Steam Client and not Uplay?
    Share this post

  3. #3
    Like wise mine wont work either , and it starting to P me off man... it isnt a steam version though.. normal retail version...

    I went from downloading cracks to downloading original updates just to get this working for my fiance... Why is UBISOFTs DRM always so CRAP!?!?! First Settlers... NOW this!!!

    Fix it please!!!
    Share this post

  4. #4
    I am launching this from Steam. Steam opens up Uplay and shows Anno, and I launch Anno from Uplay, then get the connectivity issue.

    Do I seriously have to forward ports for this game? That's something I haven't had to do in over a decade.

    Bokkie, I actually swore to never buy an Ubisoft PC game ever again after I got Settlers, because it never worked. SimCity's DRM was so bad though, and I wanted a nice city building game, so I decided to give Anno a try. In all honesty, I won't be too upset if I never get to play this game, because it's my poor judgement in thinking Ubisoft got better at this that caused this to happen.
    Share this post

  5. #5
    I was thinking about getting it cuz it was on sale on Steam...then I slapped myself and had a cold shower instead, after remembering my plight with Assassin's Creed 2.
    Looks like 3 years later, things haven't changed at all.
    Share this post

  6. #6

    Livid

    After 4 hours of getting up to speed and trying everything I can think of. I am now absolutely livid that this doesn't work.

    I've port forwarded, I've tried a DMZ, I've tried antivirus on/off, I've tried installing the 1.04 patch manually to see if that works, toyed with my IP settings to no end, had windows firewall on/off. Tried every imaginable combination of those and still no luck.

    What have I missed?

    **Rant**
    What Gives? This game has been out for a year and a half and it seems that there are still people having problems with it. This isn't acceptable, this should be something that was fixed from day 1 or as soon as the problem came to light. Customer Support spouting the same crap over and over without a definite solution just isn't acceptable in my book. Every other publisher with the exception of EA (who also try and use their own DRM service) seem to have gotten this right and don't require any messing about with any of their products.

    Why can't Ubi? How do can anyone take Ubi as a publisher seriously if they can't even get a working product to the intended audience.

    /**Rant**

    If I haven't got this working shortly I'll be requesting a refund as this is starting to feel like a waste of time.

    Dark
    Share this post

  7. #7
    Ubi-Lhainiev's Avatar Moderator
    Join Date
    Jul 2012
    Location
    Ontario, Canada
    Posts
    1,713
    Hi Darkonnis,

    I can understand your frustration, however Ubisoft Support will be the best people to ask. They can work one-on-one with you and work out a solution. Please create a ticket by clicking on the “Ask Question tab” on the top of the page: http://support.ubi.com/.

    Alternatively you may call them. You can find the Support Team in your region here: http://www.ubi.com/US/Support/InternationalSupport.aspx
    Share this post

  8. #8

    bummer

    im so on edge about getting this, I wanted to get simcity5 but that just seems terrible, small maps and online only in a single player game? f that lol


    and now from steam amazon uplay ect ect forums it seems this game is no better , I mean it s a freakin year later and people still just buying game are STILL having same problems as it was over A YEAR AGO lol




    ****! I wanna download it so bad but at 90 dollars for full game and another 15 for packs that's waaaay to much to risk and then find out im going to spend another 15 hours working to get game to work after a what 2-15 hour download? ill take my chances stepping out in front of a bus.
    Share this post

  9. #9

    Originally Posted by Mattigus Go to original post
    Hello,

    I bought Anno 2070 yesterday and I can't connect to the servers. I have a valid Uplay ID and password, with the game registered to it, but every time I try to play it, it won't let me. What can I do to get it running?
    I might have a possible solution to this nightmare!

    I just got the game in the mail after ordering it, so I've never played either the game or used uplay before. What I did
    was to let the game start (when you pass all the updates and getting the uplay maximized) and when the Ubisoft logo
    apear, I jumped to windows. What I did now was to terminate the uplay software, disregarded the warnings, and
    jumped back to the game. THIS will work. I've tested several times now to start the game, with or without the uplay
    running, and everything works now as it should. Uplay after this step can remain running, its just this first time where
    uplay has to be terminated. I dont know if its because uplay is terminated but I had to retype the serial codes for both
    the orginal game and the deep ocean.

    The game will not access the servers even if I tried like seven times before to run it with uplay in the background. I cant
    even remember how many times I've tried to access the servers with uplay running. Pressing the login button (as someone
    mentioned somewhere) rapidly or changing the host file, didnt work for me. But what I wrote above worked for me on the
    first attempt.

    Spread this possible solution around and enjoy your new functional paid game!

    Best regards
    goldenmaza
     3 people found this helpful
    Share this post

  10. #10

    Unkown error occured

    Hey, I bought this game years ago and now wanted to play it again, but it seems that I can´t log in. Thereby the game won´t start...

    Does anybody know why?
    Share this post