🛈 Announcement
Greetings! Ubisoft Connect forums are now archived and accessible in read-only mode, please go to the new platform to discuss the game
  1. #1

    Secure.ubi.com?

    Hi

    I have problem with logging to secure.ubi.com. The problem starts 2 days ago and from that day I can't login. I have reset my password 2 times but the page want's that I login again and it won't let me in. When I click option that the page remember my credentials it loops. Does anyone one have same problem? Is there any solution. I cleaned cookies and tried other clean browser, but it changes nothing.

    BR
    Sigerek
    Share this post

  2. #2
    Ubi-Lhainiev's Avatar Moderator
    Join Date
    Jul 2012
    Location
    Ontario, Canada
    Posts
    1,712
    Hi Sigerek - Please make sure your Uplay PC client is up-to-date. You might want to try uninstalling and reinstalling Uplay PC by downloading the latest version from Uplay.com: http://static3.cdn.ubi.com/orbit/lau...yInstaller.exe

    If this doesn’t help, please create a ticket to support by clicking on the “Ask a Question” tab on the top of the page at http://support.ubi.com/ for help with this issue.
    Share this post

  3. #3
    Hi

    I did not have instaled Uplay PC client because I am using PS3 for my games.

    The problem is that I can't login to http://support.ubi.com and I can't "Ask a Question". I asked question related to far cry 3 and two days ago was trying to answer becouse I have more information to report. I tried and setup new account, but I can't login also with the new account. Don't know what to do.

    BR
    Sigerek
    Share this post

  4. #4
    Ubi-Lhainiev's Avatar Moderator
    Join Date
    Jul 2012
    Location
    Ontario, Canada
    Posts
    1,712
    hmmm, what about here? -> https://secure.ubi.com/register/Login.aspx

    Can you try the forget password option?

    Alternatively, you may call them. You can find the Support Team in your region here: http://www.ubi.com/US/Support/InternationalSupport.aspx
    Share this post

  5. #5
    This is the page where I can't login - https://secure.ubi.com/register/Login.aspx. What is strange http://uplay.ubi.com works and http://www.ubi.com/ also.
    I tried reseting my password third time. The page is not logging me :-(.

    I am from Poland. There is no phone for my country on this list.

    Maybe you can contact support in my behalf?
    Share this post

  6. #6
    I think that the problem with login is for the page http://ubisoft-pl.custhelp.com. When I click on Login I am moved to https://secure.ubi.com and probably my credetials from https://secure.ubi.com are not accepted on http://ubisoft-pl.custhelp.com. Tried also other languages (http://ubisoft-en.custhelp.com and http://ubisoft-de.custhelp.com), but everywhere it is working the same.

    Is there anyone who can help me?
    Share this post

  7. #7
    Found phone to polish Support Team and problem was solved. Support page does not support polish national letters in Names.
    Share this post

  8. #8
    Ubi-Lhainiev's Avatar Moderator
    Join Date
    Jul 2012
    Location
    Ontario, Canada
    Posts
    1,712
    Hi Sigerek - What happens when you login to http://www.ubi.com/ and go directly to http://ubisoft-en.custhelp.com/app/ask . Can you try that? Do you not stay logged in?
    Share this post

  9. #9
    The page http://www.ubi.com work and it logs me in. After clicking my questions or opens http://ubisoft-en.custhelp.com the page ask me for my login again and it won't let me in. The problem was polish national char in my name (I have filled my name using PS3). Support team member change this char to normal one and fixed the probolem. Thanks for your help.
    Share this post