1. #1

    [Issue] Ghost Recon and Dual Monitor

    So I've upped my system to Windows 8 Pro (fresh install). Got the latest non-beta video drivers...

    Started up Ghost....and the **** thing is on the wrong monitor.

    I'll just copy-paste what I wrote on the Windows 8 forum:
    http://www.eightforums.com/gaming/13...or-gaming.html
    Nope, still shows up on the other monitor...

    As I said, this didn't happen at all in Windows 7 and I'm even running the same Driver Set (306.97). It's clearly something in Windows 8.

    So far I've:
    -Merged Benq and Onkyo
    -Merged HP and Onkyo
    -Switched Cables
    *Note: I can't merge HP and Benq as Windows sees the Onkyo as a display and will 'put' programs to that display....which I can't see since it doesn't have a monitor hooked to it. And if you disable it, then the audio portion is also disabled.

    In all instances Ghost Recon will run only on the Benq.
    I want to make it painfully clear that Windows 7 does not do this...it only happens in Windows 8. And that this is the only game (I play Creed and Anno) that does this.

    The only things that would affect gaming are: Raptr, UPlay, and Steam (the in-game overlays)
    And disabling the in-game overlays (even Uplay's) does not correct the problem.

    And I can't play on the other monitor because the mouse cursor is 'stuck' inside an invisible box on the main monitor. Clearly, Ghost Recon does something that no other game does...including other Ubi games

    OS: Windows 8 Pro
    GPU: Nvidia GTX 670 (Driver 306.97)
    Share this post

  2. #2
    Seems the issue is likely caused by Windows 8's "Project to second monitor" feature, which allows Metro to run in one screen and the Desktop in the other.

    How are more people not complaining about this...
    Share this post

  3. #3
    Same issue here - windows 8 pro 64, exactly like OP described.

    Also, op - keyboard commands work, and if you set your secondary montier as your primary, the mouse will work.

    But will still be on the same montier. Hoping for a fix for this soon. Wanted to show support for Ubisoft since they stopped treating PC gamers like they were all pirates.
    Share this post

  4. #4
    Sure would be nice to have a fix to this
    Share this post

  5. #5
    Just bought Future Soldier in the Steam sale and have *exactly* the same issue.

    £15 well spent
    Share this post

  6. #6
    Ubi-MoshiMoshi's Avatar Community Representative
    Join Date
    Nov 2011
    Location
    EMEA CRC
    Posts
    21,145
    Hi guys, please open a ticket with Technical Support so they can troubleshoot this with you, the link is in my signature.
    Share this post

  7. #7

    Possible fix

    Originally Posted by illutian Go to original post
    So I've upped my system to Windows 8 Pro (fresh install). Got the latest non-beta video drivers...

    Started up Ghost....and the **** thing is on the wrong monitor.

    I'll just copy-paste what I wrote on the Windows 8 forum:
    http://www.eightforums.com/gaming/13...or-gaming.html


    I want to make it painfully clear that Windows 7 does not do this...it only happens in Windows 8. And that this is the only game (I play Creed and Anno) that does this.

    The only things that would affect gaming are: Raptr, UPlay, and Steam (the in-game overlays)
    And disabling the in-game overlays (even Uplay's) does not correct the problem.

    And I can't play on the other monitor because the mouse cursor is 'stuck' inside an invisible box on the main monitor. Clearly, Ghost Recon does something that no other game does...including other Ubi games

    OS: Windows 8 Pro
    GPU: Nvidia GTX 670 (Driver 306.97)
    usually when I have the game I'm playing on the wrong monitor I just right click the desktop and check which monitor is my main. Swap this it it might fix your issue. Should be a check box next to make this my main monitor. Hope this helps.
    Share this post

  8. #8
    I'm in exactly the same situation as OP. nothing seems to work apart from disconnecting 2nd montor (this is not a real option) Changing primary monitor also makes no differance again as OP. i wish Ubi would get there act together on this one, were upto patch 1.6 & still no change. Completly unplayable.
    Share this post

  9. #9
    There was an update via Steam a few days ago...did nothing to fix the issue.

    Originally Posted by Ubi-Mush Go to original post
    Hi guys, please open a ticket with Technical Support so they can troubleshoot this with you, the link is in my signature.
    I'm pretty sure Tech Support won't have a "liked" option. This seems to be specific with Windows 8. I had the exact same hardware setup under Windows 7 and Ghost didn't do this. But I'll try..

    Originally Posted by MJOLNIRMARKFIVE Go to original post
    usually when I have the game I'm playing on the wrong monitor I just right click the desktop and check which monitor is my main. Swap this it it might fix your issue. Should be a check box next to make this my main monitor. Hope this helps.
    Ya, I've had to use 'PC Screen only' option in Charms -> Devices -> Second Monitor

    But that goes back to "liked" option. As it dumps all my stuff onto one monitor...browser window, Steam, EVGA Precision's Graphs (use it to monitor GPU Temps and Memory Usage), Raptor Desktop Dock, Recycle Bin, Taskbar, Winamp. Then I need to move all that back into position, because Ghost is the *ONLY* game that does this.


    While this is by no means a veiled threat. I've held off purchasing AS3, and FC3 specifically because I'm worried that they'll do the same thing as Ghost does. As I'm pretty sure Ghost was after the two games that DO NOT do this (AS 1 & 2, Anno 2070).
    Share this post

  10. #10
    Completly agree been on the win 8 forum too. Thanks for your help there
    Share this post