1. #41

    Mac specific problem?

    Ok so I've gone through this entire thread (and many others) and here's what I've determined.

    LatencyBuffer minimum is 2 no matter what size output buffer I use.

    OutputBufferSize seems to have no effect whatsoever. I'm wondering if this setting is even being used on Mac because I can set it as low as 2 (trying basically all powers of 2 from 1024 down) and even this low the audio doesn't crackle or glitch. And regardless of the value I use the latency seems the same to my ears. Does anyone know if perhaps this setting only affects Windows installations? If so is there a way to set the audio buffer size for mac?

    I've also tried setting ExclusiveMode=1 to try to get Rocksmith to take full control of the audio card again with no effect. The only setting that has has a noticeable effect is the LatencyBuffer and again, 2 seems to be the minimum value I can use (even if I up the output buffer size to 2048).

    This is a brand new macbook pro with very powerful hardware so I'm a little confused why it would have trouble with performance. Has anyone had luck reducing latency on mac specifically??

    Thanks
    Share this post

  2. #42
    Danny-Ramone's Avatar Senior Member
    Join Date
    Oct 2013
    Location
    Lancashire, UK
    Posts
    1,909
    Originally Posted by scamden Go to original post
    <snip>

    This is a brand new macbook pro with very powerful hardware so I'm a little confused why it would have trouble with performance. Has anyone had luck reducing latency on mac specifically??

    Thanks
    This doesn't help you, but I've run the game on a 2012 macbook pro without issues. Your hardware should be more than capable of running the game.
    Share this post

  3. #43
    Originally Posted by Danny-Ramone Go to original post
    This doesn't help you, but I've run the game on a 2012 macbook pro without issues. Your hardware should be more than capable of running the game.
    That's exactly what I thought! But out of curiosity do you get a small delay? Or is it instantaneous from playing a note to hearing it on your mac?
    Share this post

  4. #44
    Danny-Ramone's Avatar Senior Member
    Join Date
    Oct 2013
    Location
    Lancashire, UK
    Posts
    1,909
    It never occurred to me that something might be wrong, nor does it seem different playing in windows. I also never had to tweak any settings.

    Here's a thought. If you have a windows disk: create a Windows partition in Bootcamp, and see how the game runs there. The Steam licence covers both Mac and Windows.
    Share this post

  5. #45
    Scamden, What is your audio output chain? I would test with wired headphones plugged right into the laptop.
    Share this post

  6. #46
    Valtos's Avatar Junior Member
    Join Date
    Oct 2017
    Posts
    3
    Thanks for the guide. This is the best I could come up with on my laptop, a fairly new HP laptop with Intel i7 7500U and HD 620 integrated graphics.

    [Audio]
    EnableMicrophone=0
    ExclusiveMode=1
    LatencyBuffer=1
    ForceDefaultPlaybackDevice=0
    ForceWDM=0
    ForceDirectXSink=0
    DumpAudioLog=0
    MaxOutputBufferSize=224
    RealToneCableOnly=0
    Win32UltraLowLatencyMode=0
    [Renderer.Win32]
    ShowGamepadUI=0
    ScreenWidth=1280
    ScreenHeight=720
    Fullscreen=2
    VisualQuality=3
    RenderingWidth=0
    RenderingHeight=0
    EnablePostEffects=0
    EnableShadows=0
    EnableHighResScope=0
    EnableDepthOfField=0
    EnablePerPixelLighting=1
    MsaaSamples=0
    DisableBrowser=0
    [Net]
    UseProxy=1

    For some reason using Win32UltraLowLatencyMode=0 works better than Win32UltraLowLatencyMode=1. Turning it on at 224 buffer size causes the glitches and crackling to start. There is some slightly noticeable latency if I really listen for it but nothing that bothers me when playing. I usually run RS14 through my TV over HDMI and have no audio or video lag from that. The TV is made by LG and has a game mode for both audio and video so I have that on with every other fancy setting off.
    Share this post

  7. #47
    Thank you so much!
    I set Latency to 1 and maxBuffer to 200. It's no any noticable lag or crackling.
    My PC build: i5 8600k, rtx 2070, 16gb, game on HDD

    [Audio]
    EnableMicrophone=0
    ExclusiveMode=1
    LatencyBuffer=1
    ForceDefaultPlaybackDevice=0
    ForceWDM=0
    ForceDirectXSink=1
    DumpAudioLog=0
    MaxOutputBufferSize=200
    RealToneCableOnly=0
    Win32UltraLowLatencyMode=0
    [Renderer.Win32]
    ShowGamepadUI=0
    ScreenWidth=1920
    ScreenHeight=1080
    Fullscreen=2
    VisualQuality=2
    RenderingWidth=0
    RenderingHeight=0
    EnablePostEffects=1
    EnableShadows=1
    EnableHighResScope=1
    EnableDepthOfField=1
    EnablePerPixelLighting=1
    MsaaSamples=4
    DisableBrowser=0
    [Net]
    UseProxy=1
    Share this post

  8. #48
    Hello there!
    This is my setting through my behringer u-phoria um2 audio interface, don't now how goo they are:
    EnableMicrophone=0
    ExclusiveMode=1
    LatencyBuffer=2
    ForceDefaultPlaybackDevice=
    ForceWDM=0
    ForceDirectXSink=0
    DumpAudioLog=0
    MaxOutputBufferSize=160
    RealToneCableOnly=0
    Win32UltraLowLatencyMode=1

    But recently I came across a feature called rs_asio, and so my settings right now:

    https://imgur.com/a/kTXU4Kz
    Who know more about it, they add up and I get an even bigger delay?
    Share this post

  9. #49

    yes

    Originally Posted by Vector_Shift Go to original post
    I've also read that you should disable all audio output effects for your sound card.
    yes especially the EQ if you have one
    Share this post

Page 5 of 5 ◄◄  First ... 345