1. #1

    Improve Audio latency by a little. PC ONLY

    Well, before you actually try this, it is important that you have ExclusiveMode enabled through rocksmith and your sound device settings, also you should have already set your MaxOutputBufferSize to the lowest possible ( I have mine a 200). Its explained here: http://forums.ubi.com/showthread.php...tion-and-FAQ-s
    At this point audio latency was very low but still a little bit noticeble.

    The next step is to change your windows "Performance Options Settings" to "Background Services"
    Chan it from "Programs" to "Background Services"


    This will also help lower your latency to a point where is not even noticible.

    You can find the info here: http://www.brighthub.com/computing/w...les/29908.aspx
    Share this post

  2. #2
    Brick235's Avatar Senior Member
    Join Date
    Apr 2012
    Location
    New York
    Posts
    3,679
    Nice tip. Mine was already set to "background services" Not sure if that's a Win 7 default or not. Gonna try to mess around with the output buffer though.
    Share this post

  3. #3
    I set MaxOutputBufferSize to 200 and the game freezes on the Ubi logo when loading.
    Share this post

  4. #4
    Originally Posted by Apple_Horn Go to original post
    I set MaxOutputBufferSize to 200 and the game freezes on the Ubi logo when loading.
    MaxOutputBufferSize is different for every computer, you should try 1024, 512, 256, and 192. Once you get the lowest possible to work (no clicks or crackling sounds) start lowering it by 8 until you get cracks and clicks then increase by 8. For examen my game crackles at 184 so I increased it to 192 but after playing a few songs I noticed random click sounds while playing the songs so I increased it to 200.
    Share this post

  5. #5
    Awesome sauce, I'll start at 192 and work my way up, cheers!
    Share this post

  6. #6
    I actually worked my way down. I've got good latency at 136 with analog headphones. I get no sound from my digital speakers with that setting though. I'll track down some analog speakers, I'm sure I've got some in a box here somewhere that will work.

    Getting there, thanks for the tip!
    Share this post

  7. #7
    Rocksmith-God's Avatar Member
    Join Date
    Sep 2011
    Location
    Oregon
    Posts
    115
    Been trying to narrow down the best settings for my setup. Here is what I'm currently using.

    [Audio]
    EnableMicrophone=0
    LatencyBuffer=1
    ExclusiveMode=1
    ForceWDM=0
    ForceDirectXSink=0
    DumpAudioLog=0
    MaxOutputBufferSize=176
    [Renderer.Win32]
    ScreenWidth=1920
    ScreenHeight=1080
    MinScreenWidth=640
    MinScreenHeight=480
    Fullscreen=1
    VisualQuality=8

    Processor scheduling set to Background services.

    My setup for reference:
    Windows 7 64
    Intel Core 2 Quad CPU Q6600 2.4GHz
    8 GB ram
    Realtek onboard sound
    audioengine5 speakers
    Samsung 40ES6500 TV
    Share this post

  8. #8
    Down to 136 buffer and no audio lag, but it takes the game half a second to register the notes, even though there is no audio lag, any suggestions?
    Share this post

  9. #9

    very weird but work for me !!

    [Audio]
    EnableMicrophone=0
    ExclusiveMode=0 ( strange but for me if i turn of the lags are decreased!)
    LatencyBuffer=1
    ForceDefaultPlaybackDevice=0
    ForceWDM=0
    ForceDirectXSink=0
    Win32UltraLowLatencyMode=1 ( with this sound better for 5 times, and no more lags)
    DumpAudioLog=0
    MaxOutputBufferSize=576 (max buffer size without cracking)
    [Audio]
    EnableMicrophone=0
    ExclusiveMode=0
    LatencyBuffer=1
    ForceDefaultPlaybackDevice=0
    ForceWDM=0
    ForceDirectXSink=0
    Win32UltraLowLatencyMode=1
    DumpAudioLog=0
    MaxOutputBufferSize=576
    [Renderer.Win32]
    ShowGamepadUI=0
    ScreenWidth=0
    ScreenHeight=0
    Fullscreen=2
    VisualQuality=0
    RenderingWidth=0
    RenderingHeight=0
    EnablePostEffects=0
    EnableShadows=0
    EnableHighResScope=0
    EnableDepthOfField=1
    EnablePerPixelLighting=0
    MsaaSamples=0
    DisableBrowser=1
    [Net]
    UseProxy=1
     1 people found this helpful
    Share this post

  10. #10
    Chunky_Moe's Avatar Junior Member
    Join Date
    Apr 2008
    Location
    South Carolina, USA
    Posts
    16
    Holy cow, your setting is the one that worked!
    All other settings I had to do Win32UltraLowLatencyMode=0 in order for my sound to not crackle.
    If i went below MaxOutputBufferSize=576 then I also got crackle.
    I bumped mine to 600 to be safe.

    Now, which is better, Win32UltraLowLatencyMode=0 and lower MaxOutBufferSize
    or
    Win32UltraLowLatencyMode=1 and the MaxOutBufferSize=600?
    Share this post