1. #1
    Hello everybody,
    For few days I have had a problem with far cry 2, that I couldnt connect to most hoseted games, because the ping on them was too high (9999 exactly).
    All of the servers were high pinged till I've found a resolution. I've had installed hamachi to play on LAN before I have bought Far Cry 2.
    It seemed that it was first on the list of Connections,(I had to change it a long time ago, so I could play on Lan) so I had to move it lower and move my main internet connection(Wireless Network Connection)to the top of list by going to START--->Control Panel---->Network Connections and there just looked up at tab called "Advanced" in which I chose "Advance Setting..." option. A new window appeared and in it there was a tab called "Adapters and Bindings." In there hamachi should be last one and your Wireless Network Connection or other connections(it depends on what connections you're using) should be on the first place(higher up) Then when you look at the same window you should see something like this:
    Connections:
    Wireless Network Connection
    Local Area Connection 2
    1394 Connection
    Hamachi
    By doing those things my problem with Ping was fixed and I could connect to most of the multiplayer servers.
    I hope I could help...
    Share this post

  2. #2
    Hello everybody,
    For few days I have had a problem with far cry 2, that I couldnt connect to most hoseted games, because the ping on them was too high (9999 exactly).
    All of the servers were high pinged till I've found a resolution. I've had installed hamachi to play on LAN before I have bought Far Cry 2.
    It seemed that it was first on the list of Connections,(I had to change it a long time ago, so I could play on Lan) so I had to move it lower and move my main internet connection(Wireless Network Connection)to the top of list by going to START--->Control Panel---->Network Connections and there just looked up at tab called "Advanced" in which I chose "Advance Setting..." option. A new window appeared and in it there was a tab called "Adapters and Bindings." In there hamachi should be last one and your Wireless Network Connection or other connections(it depends on what connections you're using) should be on the first place(higher up) Then when you look at the same window you should see something like this:
    Connections:
    Wireless Network Connection
    Local Area Connection 2
    1394 Connection
    Hamachi
    By doing those things my problem with Ping was fixed and I could connect to most of the multiplayer servers.
    I hope I could help...
    Share this post

  3. #3
    or you can just unblock ping block in the router and open ports that are listed on the forums here, solves the problem as well.
    Share this post

  4. #4
    From reading a lot of forums, many people had the same problem and the answer for it was to unblock some ports. It didn't help most of them, so I would prefer checking your network connections, because its much better when the game reads your wireless ip then that from hamachi right>?
    Share this post

  5. #5
    I tried opening ports an all that as well, to no avail. This is NOT always the problem, even though some here like to pretend to know it all.

    I sure dont, and I'll try this method now.

    BTW, I just built my own computer, so Im not completely PC illiterate.
    Share this post

  6. #6
    slippsycho's Avatar Banned
    Join Date
    Jan 2009
    Posts
    124
    sure 9999 ping is really your problem here?

    i join 9999 ping matches all the time, and play them with no lag...
    Share this post