1. #1
    WOLFMondo's Avatar Senior Member
    Join Date
    Dec 2003
    Posts
    4,910

    How to get IL2: 1946 v4.11 or older running in widescreen

    *** NEW *** - Update to version 4.12 or later, native widescreen support is now included. For patch order and download links, see http://www.mission4today.com/index.p...p=show&kid=584

    If you're keeping older versions for online server compatibility, mod compatibility or nostalgia reasons, follow the instructions below.



    Possibly the most asked question of all time, other than when is patch x.xx coming out?

    1) Open the folder where IL2 46 is installed, its usually 'c:\program files\ubisoft\IL2 Sturmovik 1946' if you used the default install option.

    Another way of finding this is to right click in the IL2 46 desktop icon to bring up a drop down menu, click on 'Properties' to open up the shortcuts properties menu, go to the 'Shortcut' tab and click on 'Find Target'.

    2) Look for a file called 'Conf.ini', open it up in Notepad or a text editor.

    3) Look for the following lines of text, they should be near the top:

    [window]
    width=1920
    height=1200
    ColourBits=32
    DepthBits=24
    StencilBits=8
    ChangeScreenRes=1
    FullScreen=1
    DrawIfNotFocused=0
    EnableResize=0
    EnableClose=1
    SaveAspect=0
    Use3Renders=0

    4) Edit the lines 'Width' and 'Height'. These lines correspond to the resolution IL2 will display in. Enter in your screens native resolution or the resolution you want to play IL2 in.

    The example above is for a 24" 16:10 screen. A 19" 5:4 screen is 1280x1024 which is standard resolution for that sort of size TFT/LCD. A 16:10 19" widescreen is 1280x800 etc. More info on screen sizes can be found here.

    5) Look for 'EnableResize=' and set it to 0.

    6) Look for 'SaveAspect=' and set it to 0.

    7)Save the file, close it and run IL2.

    For a full description of the different display options in IL2 please look here and for some helpful setup guides look here

    *edit*

    Please note that changing any options within the 'Setup.exe' or changing the in game video settings will overwrite the conf.ini and the resolution changes you've previously made with a resolution IL2 supports.

    Just follow the steps again once you've made your desired changes within Il2 or the 'setup.exe' to get the resolution you want.

    Alternativly use IL2 Stab. This programme allows changes to be made without the need to go into IL2 setup or the conf.ini for most user settings.
    Share this post

  2. #2
    Thanks WOLFMondo.

    As widescreen becomes more and more the rule and less the exception, this question may appear more than it does now.

    Also, I'll add that the person setting up widescreen should know that the initial splash screen will still have the black borders on the sides, but when the game itself is entered (or once you're in cockpit) the game will display without the black side borders.
    Share this post

  3. #3
    Does this work on Pacific Fighters as well?
    Share this post

  4. #4
    Share this post

  5. #5
    I don't know why, but this doesn't seem to be working for me. I enter 1680x1050, and I still get the black panels on the side. I didn't see a place to select the new video mode in the video options either.
    Share this post

  6. #6
    WOLFMondo's Avatar Senior Member
    Join Date
    Dec 2003
    Posts
    4,910
    There won't be an option within IL2 for 1680x1050. If you change video settings or settings from within 'setup.exe' you will then need to go back and edit the conf.ini to get the resolution you require.

    Make sure you also double check the EnableResize=0
    SaveAspect=0 settings and that they both are =0 once you've edited the resolution. That should get rid of the black bars.

    If in doubt post your conf.ini here.
    Share this post

  7. #7
    And remember, you will have black bars in the menu screens but it should go fullscreen when you start flying.
    Share this post

  8. #8
    wayno7777's Avatar Senior Member
    Join Date
    Jan 2004
    Posts
    2,546
    For 19" wide screen it will stretch and you will lose one side, so I have to put a 1 in save aspect. I get the bars but no stretching. I wish I could get full screen without stretching....
    ps. also 19" wide is 1440 x 900
    Share this post

  9. #9
    WOLFMondo's Avatar Senior Member
    Join Date
    Dec 2003
    Posts
    4,910
    That a WXGA+ widescreen 16:10 though, you can get 1366x768 19" too which is essentially 720p. Theres too many different formats, standards and terms out there its confusing to the consumer.
    Share this post

  10. #10
    Well, I finally got widescreen mode working. It looks like it was a Vista "issue". If I run the program from the desktop icon and have it set to "Run as Administrator", then I get my widescreen view. Without that, I just have the regular view, regardless of what I have set in the conf.ini. This makes no sense to me, but thats what does the trick.
    Share this post

Page 1 of 9 123 ... Last ►►