1. #1
    Newbie Needs Help

    I have this joystick http://www.saitek.com/uk/prod/st90.htm

    This works in control panel within windows XP, though when I fire the game up it has zero effect.. any ideas?

    The HOTAS settings seem greyed out and cant be changed.

    any ideaS?
    Share this post

  2. #2
    Kuna15's Avatar Senior Member
    Join Date
    Aug 2005
    Posts
    2,042
    Make sure that your joystick is the default one -- open Control Panel;



    That may be the problem, especially if you have installed two or more controllers. Check that out .
    Share this post

  3. #3
    Thanks for the reply, I checked that and that's correct and still the joystick isnot recognised in the game.

    Anything else?
    Share this post

  4. #4
    bolox00's Avatar Senior Member
    Join Date
    Jun 2003
    Posts
    551
    when you run il2setup, in the joystick tab is use joystick ticked?
    Share this post

  5. #5
    bazzaah2's Avatar Senior Member
    Join Date
    Mar 2003
    Posts
    1,259
    I've had that happen twice now since the new patch. I just unplug the USB and reinsert. seems to work or have just quit and restarted the game. Hope that helps.
    Share this post

  6. #6
    I fixed it..

    I took a look at the conf file and in there i changed the 0 next to joystick to 1.

    C:\Program Files\Ubi Soft\IL-2 Sturmovik Forgotten Battles

    [rts]
    ;ProcessAffinityMask=1
    mouseUse=2
    joyUse=1
    trackIRUse=1
    DisableIME=0
    locale=


    p.s. I'm not game programmer, this is my first game, and to have to find stuff like that in a conf file is basically ****ing ridiculous!... Shoddy programming there!
    Share this post

  7. #7
    TGrimReaper,

    There's a program called either PFSetup.exe or IL2Setup.exe in the folder where you installed the game. It's also available via yer Start Menu.

    It's got all kinda settings, which you can modify.
    One of 'm is under them item 'Joystick' and it's a toggle. Called 'Use Joystick'.

    You can switch it on, and you can switch it off.

    It's mentioned in the PF Manual on page 12 ...

    So, no shoddy programming, if anything shoddy here, it must be the thing in front of yer monitor, touching the keyboard!
    Share this post

  8. #8
    That's good to know.

    The point about programming is, that that file (even though in a manual) is not clearly available.

    I'm thinking a user without much PC experience would never find that file for the following reasons:

    1. there is no link to settings within the game itself (there should be)
    2. where is the manual, there is no link to it within the game itself, and in the file menu.

    Settings SHOULD be extremely easy to find WITHIN the game...

    Just a though.. good game though.
    Share this post