1. #41
    Originally posted by Gannet7:
    Thanks Revian, since multiple people have reported those issues I've added them to the first post now. Regarding the video, do you also have GMA graphics?
    How can I find that out? I go to "About this Mac" and don't see anything that says "GMA" under the Graphics/Displays tab. I'm using a MacBook Pro, 10.5.8 (not 10.6 as it would seem, ha), 2.33 GHz Intel Core Duo, 2GB 667 MHz DDR2 SDRAM. What else can I inform you?

    In addition, I spoke too soon. There is at least one other crash in Spire: when I went to look through the telescope . It's going to be frustrating to save all the time if that's the only solution.

    Thanks for your help.
    Share this post

  2. #42
    Okay, I'll assume you don't then since I'm pretty sure the Pros never used GMA.

    The 1.0.3 update was supposed to fix some crashes in Spire, so I'm suspecting I may not have applied it properly. Right-click on your Myst IV app and choose "Show Package Contents", then navigate to Contents/Resources/transgaming/c_drive/Myst IV Revelation/bin. Replace the file "Myst4.exe" with this one. Let me know if that changes anything.
    Share this post

  3. #43
    Unfortunately no . I tried both:

    - opening your saved game file to where i had left off by the telescope, tried to examine it, and it crashed
    - opened my saved game file and tried to go down the four flights of steps and it too crashed.

    what next?
    Share this post

  4. #44
    Darn. Okay, next try:
    In the same folder, try replacing m4_thor_rd.dll with this one.
    Share this post

  5. #45

    I only tried your saved game (which I've progressed within Spire, the only glitches so far being the telescope and 4th flight of stairs) but I didn't try my original saved game. I assumed it wouldn't make a difference.

    What the heck's goin on here?
    Share this post

  6. #46
    That's all I got. If the game shows 1.03 in the corner when you open it, then it definitely is at 1.03. I guess the crashes are related to an incompatibility between cider and some aspect of your system. You'll have to use the hint system or a walkthrough to avoid the telescope.

    Since you're not running 10.6, the Mac native version of Myst IV should work fine. Grab the setup and updater that I linked to on the previous page.
    Share this post

  7. #47
    I tried installing your new version of myst 4, it says its installed successfully, but when I go and load the game I see a black screen then it quits and reverts back to the desktop. It does not give an error message so I am confused here.
    Share this post

  8. #48
    Hi bberry,

    What version of OS X are you running?
    Please also post a complete file listing of the app - open Terminal and enter this command:
    ls -lR /Applications/Myst\ IV\ Revelation.app
    Share this post

  9. #49

    I'm running Mac OS 10.5.8. I've installed MystIV with the installer you suggested. It briefly worked once. I saw the opening video. But then it crashed and now it won't reopen. When I double click it I get this message:Unable to copy file /Applications/Myst IV Revelation.app/Contents/Resources/Preferences/system.reg to /Users/mjsdesert/Library/Application Support/Myst IV Revelation/system.reg

    I'd appreciate any help.
    Share this post

  10. #50
    Hi mjsdesert,
    Delete this folder:
    /Users/mjsdesert/Library/Application Support/Myst IV Revelation
    That should let it launch again. If it crashes again though, let me know exactly where it happens.
    Share this post