After reading the last page of this thread, in which one player got Myst4 working on 10.14, I DL'd the installer. When I tried running it, I got an error message that the variable m3 was not defined. I assume this is in reference to the following lines:

on run
set m4 to my (NSWorkspace'ssharedWorkspace'sURLForApplicationWit hBundleIdentifier:"com.ubisoft.myst4")
if m4 is missing value or not update(m3) then fullInstall()
end run

What can I do about this? Can I unlock the file and add your definition in Script Editor? Or is there some other reason why it won't work for me? I'm using OS10.12.6.

EDIT: I tried it again after posting and it seemed to be working. It requested both discs, and completed disc 1 without a hitch. Sometime during disc 2, I got an error message "Apple Event timed out (-1712)." The Revelation app appears to be intact, weighing in at 7.51 GB, but it won't launch.

EDIT: And it works! I deleted the Revelation preferences folder and everything works now, although the transitions between game areas is really s-l-o-w.