1. #81
    How do you assign the quest in your Assign_Quests event? Scenario_addQuest? I used that one and it does pop up a quick dialogue win saying I got a new quest and its name.
    Share this post

  2. #82
    Yes that's what I use. But I'm not seeing the notice.

    And here's a puzzle, ran the map again and now it does not detect when I walk through the gate. I made no changes to the map :[
    Share this post

  3. #83
    Yeah, I think there are some issues with the triggers in the game perhaps. Unless you already did, try starting Heroes VI normally, choose your map in the list of maps and start it that way instead of using 'Test scenario' from the editor. I have a sneaky feeling there may be some glitches go that route.
    Share this post

  4. #84
    I never use the 'test scenario' from the editor.

    I save it, then close it. Then I copy it from my 'development' folder over to the scenario folder, then I run it from the game.

    Better safe than sorry. I've had the editor crash when saving about 1 in 5 times that I save. I've even had it crash when I've done nothing in the editor.

    Save.. ok.
    Wait 5 minutes.
    Save again.. crash.
    Share this post

  5. #85
    have you posted these save crashes in the Bugs section on this forum? Perhaps they'll address it in the next patch. And perhaps it'll be world peace at the same time...
    Share this post

  6. #86
    I'm almost ready to just give up on making a map. Works then doesn't work.. with no changes made. Saves fine... crashes when saving.. with no changes made.

    And developers who can't even care enough about the people who spent their money to come and post on this forum.

    The more effort I put in the more I hate this game.
    Share this post

  7. #87
    Sad. Seems like this game joins the list of those rushed for release despite tons of unfixed bugs. I may be of the more patient and optimistic (not to mention forgiving) kind than most, so I await fixes in patches. However I understand fully that this does not apply to everyone.
    Share this post

  8. #88
    hey there...

    Im currently working on a MP map.. and have a quick little question..

    I have "painted the border or area control but I am in doubt on how to place these colored obelisk that is shown at the borders...do they appear by them selfes when playing or how to place them??
    Share this post

  9. #89
    Marzhin93's Avatar Senior Member
    Join Date
    Mar 2004
    Location
    Paris, France
    Posts
    1,563
    The second guide deals with quests (among other things) and will be posted later today.

    Originally posted by raider_manhc:

    I have "painted the border or area control but I am in doubt on how to place these colored obelisk that is shown at the borders...do they appear by them selfes when playing or how to place them??
    The obelisk need to be placed manually. You'll find them in the Entity Library as AreaObelisk. Basically, if the tile where you put the Obelisk belongs to an Area of Control, the Obelisk will automatically be of the same colour as the player controlling the Area.

    Originally posted by molinaro:

    I'm almost ready to just give up on making a map. Works then doesn't work.. with no changes made. Saves fine... crashes when saving.. with no changes made.
    I'm sorry to hear that. I've been using the map editor for two years now and I have encountered only one crash in all that time, so it's unfortunate you suffer from those repeated glitches. Probably there's some conflict with your PC itself. Can you tell me what is your config?
    Share this post

  10. #90
    Originally posted by molinaro:
    I'm almost ready to just give up on making a map. Works then doesn't work.. with no changes made. Saves fine... crashes when saving.. with no changes made.

    And developers who can't even care enough about the people who spent their money to come and post on this forum.

    The more effort I put in the more I hate this game.
    Funny how you mention it; the more effort I put into this the more interest I gain. There's just something special about solving even the smallest mysteries. I'm not much of a map builder, but I enjoy finding out how the actual maps work.

    I do however also experience crashes with the map editor. It happens when I press "Test Scenario" for then to return to the editor, in which everything is gone except the terrain itself. I can still insert new units/doodads/triggers and everything functions, but all that was made before testing just isn't visible and saving the map crashes the editor.
    Reloading the map after each test resolves the issue, but it is definately reproducible on my machine. General setup: i7-2600K, gtx 580, 8GB 1333 MHz Ram, P8Z68 deluxe MB.
    Share this post