1. #1
    In the "Mentor's Guardian" level... You have to "save all citizens" but I don't see how it can be done....

    As soon as I've had the cut-scene with the Templar by the door, he kills one of his hostages hence denying the full sync...

    I've tried sneaking my way around the whole map to try and cross completely undectected, but it didn't change anything.
    I've also tried another way of approach to get to the courtyard (climbing the tower that faces the wall of Masiaf's stronghold), hence completely avoiding the cutscene, but only to find the courtyard completely deserted (and having to start over from scratch because there's no way to get back out of the courtyard once you're in...)

    Anyone got it yet?
    Share this post

  2. #2
    I've tried making sure all the Templars on the map were killed before going to the green mark and that did not help either... (Unless of course there's a "well-hidden one" which I didn't find when I paced the map back and forth in search of any potential survivors.)

    It's the only Memory which is not at 100% sync for me and it's getting pretty annoying... Been playing it over and over for the last few hours, trying everything I could think about but still get the same cutscene and the Templar kills a citizen right away after it each time denying full-sync.

    (I know double-posting isn't well viewed but since there was over 30 views of this subject, I felt like posting the new information a fresh post rather than editing would be better...)
    Share this post

  3. #3
    If its the one I think, you have to save all the citizens AS you fight your way to the castle. BEFORE you meet the knight I assume. I didn't manage to. They are shown as small circles on your mini map.
    Share this post

  4. #4
    Thank you frigabond!

    I've just done that and got the full sync!

    For anyone who'd wonder what we're talking about (and because that part might be one of the hardest objectives to understand):

    As you make your way up the map, 4 small black dots will appear on the small map at the bottom of your screen, you need to go to each of these points and kill the Templars there to "save the citizens". Once you've got all 4 saved you'll get the "secondary objective completed" message and you can then proceed to the cutscene.
    Share this post

  5. #5
    No problem..

    I'll go back later for my 100%. Just lost all my assassins trying to to get to room undetected to eavesdrop for sueliman!! Damn those janissaries!!

    Got a LOT of work to do now to replace them. GRRRR.
    Share this post

  6. #6
    Kytr's Avatar Senior Member
    Join Date
    Nov 2010
    Posts
    1,067
    Thanks. That one was giving me terrible grief -- I tried killing every templar and ignoring them an sprinting straight through to see if that would work (both methods indicated that save all citizens had not failed during the final cut scene, then failed as the mission closed). This one is very irritating.
    Share this post

  7. #7
    jmk1999's Avatar Moderator
    Join Date
    Jun 2004
    Location
    United States
    Posts
    7,490
    i did it in on the first try. just find the black dots when fighting up the mountain. the executed hostages don't count... in fact i believe he killed two hostages on mine.
    Share this post

  8. #8
    Gil_217's Avatar Senior Member
    Join Date
    Sep 2011
    Location
    The Riverlands
    Posts
    715
    LOL, so we only know what we have to do to get full synchronization after we actually have the chance to do it.

    I failed to get the full sync because the indication appeared after, not before.FAIL.

    Now that we are talking about fails, did anyone notice that in Maria's database it says that Altair killed de Sable in 1192. Are you ****in kidding Ubisoft. You can't make errors like that for God's Sake.
    Share this post