1. #2831
    Bug: Even though all campaigns/expansions are unlocked, custom maps are not unlocked:
    http://img854.imageshack.us/img854/2...mnightmare.jpg
    Share this post

  2. #2832
    Not Found

    The requested URL /patches/H..._2.1_efigs.exe(Digital) was not found on this server.
    Cant download the patch
    Share this post

  3. #2833
    Go here for the correct links:
    http://forums.ubi.com/showthread.php/767211-Incoming-Patch-2-1-release

    They are at the end of the 2nd post.
    Share this post

  4. #2834
    So I'm just now playing Danse Macabre, and having finished the first mission, I was ready to move on to the second one. But there is a problem right after the last fight and the two cut scenes. When I press "Next Map", instead of going to the next map in the Danse Macabre campaign, it glitches and switches to the 2nd map of the Pirates of the Savage Sea!

    You are given the choice to continue or to quit. Pressing "Continue" does nothing (perhaps because I haven't played Pirates yet), so there is no choice but to quit.

    I replicated the behavior four times, having done the last fight four times, and the glitch occurs every time, so I absolutely cannot proceed to the 2nd mission in Danse Macabre. When I press "Quit" and go back to the campaign menu, the only option I have is to play the 1st mission again.

    Has anyone else experience this bug? Or is this newly broken in the just released patch?
    Share this post

  5. #2835
    I have tried playing the darkelf campaign, but when the opening cinematic starts, my entire screen goes dark, not black just very low brightness and some of the particle effects turn to little black squares. After some fiddling in the games options the screen went bright again, until i used the underground entrance, and stuff went dark again.
    I find this very anoying and i'm wondering if anyone else has the same issue

    The same thing happend when i started the new necro campaign.
    Haven't tried the old campaigns yet, but i fear they might have the same issue
    Share this post

  6. #2836
    arain.20's Avatar Member
    Join Date
    Aug 2005
    Location
    Salamanca
    Posts
    84
    When switch some times between Magic or Might affinity hero, the game crash.
    Share this post

  7. #2837
    I have just bought the deluxe version of the game from steam and then bought the expansion packs. At the moment I can play the expansions but not the main campaign. I have allready posted on a thread that focuses on the issues of new customers via steam but it has been ignored for two days. Im hoping there is more attention paid to this bug thread. A response would be appreciated here and in the thread made specifically for this problem.
    Share this post

  8. #2838
    Originally Posted by arain.20 Go to original post
    When switch some times between Magic or Physic affinity hero, the game crash.
    I guess you mean Might with phyic hero...
    Share this post

  9. #2839
    I waited almost a year that will correct a mistake in My Dynasty, but even with the release of patch 2.1, this problem has remained.
    I can not change the title in the selection window. The list of titles bigger than this window and i cant choose the title what i need.
    Can anyone fix this problem - add scrollbar and did that menu open down, not up.

    Share this post

  10. #2840
    ChrisD.1's Avatar Senior Member
    Join Date
    Jul 2012
    Location
    Beyond Ashan
    Posts
    516
    Originally Posted by Storm-Giant Go to original post
    A patch creating new bugs? It seems history repeats itself, over and over!
    and yet we buy their stuff and continue to support ubisoft

    and so many portraits for nothing!i cannot use them for creating a new hero for the campaigns neither i can use them for my sig...
    and the new heroes do not appear in the taverns once playing campaign/custom game!!
    Share this post