1. #1
    Hello i have a computer with
    hyper threading

    these are my specs:
    Time of this report: 6/2/2008, 23:05:46
    Machine name: DENNIS
    Operating System: Windows XP Professional (5.1, Build 2600) Service Pack 2 (2600.xpsp_sp2_gdr.070227-2254)
    Language: Dutch (Regional Setting: Dutch)
    System Manufacturer: ASUSTek Computer INC.
    System Model: P5PL2
    BIOS: BIOS Date: 09/21/06 14:00:55 Ver: 08.00.10
    Processor: Intel(R) Pentium(R) 4 CPU 3.40GHz (2 CPUs) (Normaly 1 CPU but thanks to Hyper Threading it shows up as 2)
    Memory: 3456MB RAM
    Page File: 485MB used, 4811MB available
    Windows Dir: C:\WINDOWS
    DirectX Version: DirectX 9.0c (4.09.0000.0904)
    DX Setup Parameters: Not found
    DxDiag Version: 5.03.2600.2180 32bit Unicode

    My Problem: beyond good and evil runs to fast becouse of the hyper threading function.

    I found a solution to this by Turning of hyper threading in the BIOS Setup on startup.

    But... is there any other ways to solve this problem becouse when hyper threading is turned off my computer is pretty slow

    thank you for you time and effort

    Your Sincerely,
    Maniak NL
    Share this post

  2. #2
    There are several solutions for this problem, but I think the following one is one of the easiest:

    http://forums.ubi.com/eve/forums/a/tpc/f/561108232/m/21...981061366#7981061366

    The solution mentioned is for Prince of Persia but the same method should work for BG&E.
    Share this post

  3. #3
    It still doesnt work i tried the

    .bat file
    with "start /affinity 1 bge.exe"

    and when double clicked on it it gave me a small black console for like 0.5 miliseconds and it closes again without doeing anything (yes i put it in the same folder where bge.exe was located)

    Please help
    Share this post

  4. #4
    Sorry about that, apparently it only works on Vista. This should work on XP: Start Task Manager (bring it up by pressing Ctrl+Alt+Del on windows desktop) and go to the Processes tab. Now when you start the game, you should see a bge.exe process running there (you may have to alt-tab). Try to right-click bge.exe, click "set Affinity" and then uncheck CPU 1, so that only CPU 0 is selected.
    Share this post

  5. #5
    Thanks alot it worked liked a charm
    however it seems to run better when i only check CPU 1 in stead of only using CPU 0
    Share this post