1. #1
    I play AC:B for a while and after about 20-30 minutes the game freezes and the last sound is repeated and forces me to restart my PC
    I use Intel quad core processor 2.66Ghz
    Nvidia geforce GTX 260
    i use dual monitors ( i have tried disabling this though) And i have updated all of my drivers the problem still persists it's happened about 8 times today and i can't find a single fix for this at all, i've tried installing older graphic drivers but it still happens and i've ran out of ideas can anyone help? Thanks.
    Share this post

  2. #2
    ---------------------------------------------------------------------------------------

    Try to disable and turn OFF Multisampling and VSync, at the game's Graphics options. Do you crash in SP or MP ? This could be a SOUND card issue. Try to disable any HD audio device.

    Have you also tried running/playing the game On 2 CPU cores, or even 1 core (depending on your processor i.e. Quad CPU, i7 etc.) ? Not sure if this can solve your problem, but there is no harm in trying it. What is the exact Model of your CPU ?

    After you have loaded the Game's Main Menu, Open Task Manager (CTRL+ALT+DEL/CTRL+SHIFT+ESC) and Click on the Processes Tab. On the Processes tab, at the bottom click on the 'Show processes from all users' Button. Now Right click the process i.e. ACBSP.exe, and Click on the 'Set Affinity' option, and then 'Uncheck' any 2 boxes labelled as CPU 0, CPU 1 etc., and click on the OK button. But first Launch the game and then press 'ALT-TAB' to go back to the desktop, and now open the Task Manager, and follow the above method. Press 'ALT-TAB' to go back to the game. You can also check the CPU usage after playing the game for a while. By any chance, is your GPU showing any signs of Overheating, after 30 minutes ?

    Just make sure to run the process i.e. ACBSP.exe, with any 2 cores of the CPU. Or Uncheck any 3 boxes, to play the game on a Single CPU core. Btw, does the game fully utilize all the CPU cores ??

    Another method: Insert the following command inside the Target line at the game's Shortcut TAB. Make a Shortcut of the game's .EXE and insert the following command (Right-click---->Go to properties---->Shortcut TAB):

    C:\Windows\System32\cmd.exe /c start /HIGH /affinity 3 ACBSP.exe

    This will allow the game to run on High priority, and only on 2 CPU cores. You can also Lower the process priority if needed.

    I don't suggest giving the Process, a Higher Priority under Windows 7, because of better Memory Utilization. You can also use this tool for setting the CPU affinity/priority:

    http://edgemeal.110mb.com/PriFinitty/index.htm

    As a side note, try launching the game under 'Windows XP SP2 Compatibility Mode', and see if this makes any in-game difference or not ? This can be easily done under Windows 7/Vista.

    Try to close every other Background process while gaming, and if by any chance you have 'ASUS GamerOSD', and/or SmartDoctor installed, then kindly remove it. It has known to create a Lag with some of the PC titles.



    ---------------------------------------------------------------------------------------
    Share this post

  3. #3
    Does this happen in multiplayer or singleplayer?
    If in multiplayer, what sound card do you have?
    Share this post

  4. #4
    Hey, thanks for the reply. I had already tried turning off some of the graphic options in game but it kept crashing the processor it Intel(R) Core(TM) 2 Quad CPU Q8400 @ 2.66GHz (4 CPUs) from my dxdiag i will try running it on fewer cores but have also tried setting the priority to high and realtime but both crash. I will also try running in XP SP2 mode also i don't know if i played Multiplayer longer but these crashes are on the multiplayer and not the singleplayer, as i have managed to play singleplayer for a while without crashing but when i switch to multiplayer i get about 20-30 mins again. Not sure if that has anything to do with it, also i don't think my GPU is over heating but i'll check that and the CPU usage whilst playing it next. I'll try a few of these methods and get back to you, thanks
    Share this post

  5. #5
    Originally posted by ShacoJester:
    but these crashes are on the multiplayer and not the singleplayer, as i have managed to play singleplayer for a while without crashing but when i switch to multiplayer i get about 20-30 mins again. Not sure if that has anything to do with it.
    YES IT DOES!
    I'm gonna guess you have an on-board sound card (prolly realtek?) huh?
    Well you need a new sound card else you will just keep crashing.
    It's actually caused by punkbuster(AC:B multiplayer anti-chaet).
    Alot of games have the same issue.
    I found a really old realtek driver, but not sure if it works because I can't connect to multiplayer all day.
    Share this post

  6. #6
    Yes this does seem to be in multiplayer my dxdiag reads:
    Name: Speakers (High definition Audio Device)
    HArdware ID: HDAUDIO\FUNC_01&VEN_10EC&DEV_0888&SUBS
    Manufacturer ID: 1
    Product ID: 65535
    Type: WDM
    Default Device: Yes

    just a side note i also have 2 other sound tabs showing different names of: Digital Audio (S/PDIF) (High Definition Audio Device)

    The drivers are Hdaudio.sys
    Version: 6.01.7600.16385 (english)
    Date: 14/07/2009 00:07:00
    WHQL Logo'd: n/a
    Provider: Microsoft

    I know that the drivers are incredibly old but i've scanned for updates and found nothing, does anyone have a site where i can manual update these?
    Share this post

  7. #7
    I have exactly the same problem.
    The freezing only happens in multiplayer but not singleplayer.
    And I'm using an onboard sound card as well.
    But I thought my HD4850 has built in sound card in it?
    Anyway is there a way to solve this problem?
    Share this post

  8. #8
    And as a side note.
    The ACB MP will freeze the computer even when it's in background.
    I happen to open ACB MP but alt-tabbed to do something else. And after a while the computer freezes.
    Share this post

  9. #9
    I'm having the same sort of problem, but in single player. I have a AMD Phenom II X4 810 processor, a SB Audigy 2 ZS sound card, an ATi HD 4870, and Windows 7 64-bit, which I installed a month ago. It said it got the most up-to-date drivers for me, but I considered maybe installing them manually.

    Basically I'm at my limit. It's crashed about 30 times, same as the guy who started this thread, and today it crashed while saving, and my save file got corrupted. Now I have to start over, which doesn't bother me because I love the game, but this is a game-breaking crash. I need help please!!!
    Share this post

  10. #10
    Originally posted by OsontheUnsound:
    I'm having the same sort of problem, but in single player. I have a AMD Phenom II X4 810 processor, a SB Audigy 2 ZS sound card, an ATi HD 4870, and Windows 7 64-bit, which I installed a month ago. It said it got the most up-to-date drivers for me, but I considered maybe installing them manually.

    Basically I'm at my limit. It's crashed about 30 times, same as the guy who started this thread, and today it crashed while saving, and my save file got corrupted. Now I have to start over, which doesn't bother me because I love the game, but this is a game-breaking crash. I need help please!!!
    So this is single player, right?
    Because the OP is talking about multiplayer freezing. You got enough RAM in your machine?

    And to the OP: I have the same problem, however, compatibility set to WinXP SP2 kinda stabilized it a bit for me. And I played a few games without freezing/crashing yesterday - for me it only happens in session, never in the menu. I also made sure I had the latest Catalyst CC installed (11.2 was released february 15th, which included a driver update)
    I hope that actually did fix it for me, but I can't be sure.
    If you wanna try everything, I suggest looking for the realtek R258 driver, I heard for some people it fixed their problems. Although, the fix hasn't been consistant with everyone who tried it...
    Share this post