1. #1

    My clicks don't register on Ubisoft+

    I've been replaying all the games in the series using UPlay Plus instead of shelling out a hundred dollars which I appreciate. I've had a lot of fun and I really like this series but I was just stopped dead in my tracks. I put AC4 into my games catalog before playing it and after completing AC3 I tried clicking on it and playing but when i click play or the blue arrow nothing happens. I tried going through the shop and through google but nothings worked. If anybody knows what to do or has had this happen to them please respond. Also I've been able to download all other games and click on them except this one for whatever reason. Thank you.
    Share this post

  2. #2
    Ubi-Keo's Avatar Ubisoft Support Staff
    Join Date
    Jul 2017
    Location
    UK
    Posts
    5,121
    Hi greenlizard67,

    Welcome to the forum.

    I'm pleased to hear that you have been enjoying playing through the Assassin's Creed games.

    I can confirm that there is a known issue with the Ubisoft+ version of Assassin's Creed IV: Black Flag, this is being investigated.

    I apologise for the inconvenience caused.
    Share this post