🛈 Announcement
Greetings! The-Settlers forums are now archived and accessible in read-only mode, please go to the new platform to discuss the game.
  1. #1

    Settlers 7 HE - LAN games have begun to desync every time

    Hi, I have been enjoying playing this in 2 player co-op on LAN, then around December time, our games multiplayer games began crashing, usually within the first 5 minutes or so.- with a desync detected error. Previously this happened on rare occasions and we found multiplayer was stable after restarting pcs. Now it's happening every time (10+ attempts in recent weeks)

    I dont understand what goes into running this game in multiplayer or where the fault could be, but we'd really like to be able to play it again.
    This now happens every time we attempt to play multiplayer - both with various standard maps, as well as maps I modified by mapforge to increase victory points (both cases worked fine before december). Also map size doesnt seem to make a difference - it at least affects maps from huge to medium.

    Any advice would be appreciated, would love to be able to play again.
    Some things I dont understand about the architecture:
    What does desync really mean? Is the network lag between the two pc's too great to support multiplayer? (its a gigabit network with not much other traffic)
    We are playing on LAN, but is our mutiplayer session going through a web server? (trying to understand if the issue is definitely within the LAN side)
    If it is going through some Ubisoft server, have there been any updates to the server that have caused instability for others?

    Below is an extract from a recent desync log:
    [ 2021/01/20 20:36:43: 380 ]BootUp Network Engine.

    Loading map: Maps\Menu\Castle_Forge_Map using template (none)
    Loading screen counter: 299 of total 300
    Timestamp: 369372106264
    [ 2021/01/20 20:39:15: 2 ]Player 1 initialized in state engine!
    [ 2021/01/20 20:39:15: 2 ]Player 4 initialized in state engine!
    [ 2021/01/20 20:39:15: 2 ]Size of m_StatePlayerInformation: 2

    Loading map: Maps\Skirmish\s02_m05_Twin_Peaks using template (none)
    Loading screen counter: 343 of total 300
    Timestamp: 2302113054624
    Desync detected in turn: 761
    Message tracer:

    ********** DETAILED DESYNC INFORMATION **********

    ActivePlayers: 4
    AnimalsCount: 230
    AnimatedDoodadsCount: 19394
    BattlefieldCount: 0
    BlueShellCount: 0
    BridgesCount: 32
    BuildingsCount: 14
    CampCount: 40
    CarriersCount: 19
    ClericsCount: 0
    CliffsCount: 17422
    CombatCount: 0
    ConstructionBuildingCount: 4
    ConstructionSiteCount: 31
    ConstructorsCount: 12
    ConsumerBuildingCount: 15
    Coop mode: 1
    CultureDoodadsCount: 0
    DecoTreesCount: 5320
    FieldsCount: 5
    FortificationsCount: 516
    GatherersCount: 0
    GeneralsCount: 27
    LogTaskCount: 166
    MilitaryUnitsCount: 332
    MineCount: 30
    OrnamentalsCount: 10
    PileCount: 111
    QuestCount: 294
    RandomCount: 26132
    RandomSeed: 97000140
    RefinersCount: 0
    SoundsourcesCount: 67
    SpawnsCount: 58
    SpecialEffectsCount: 0
    StorehouseCount: 13
    StreetsCount: 1509
    TechSlotCount: 22
    TradersCount: 0
    TreeCount: 37831
    WinnerID: 255
    WorkshopCount: 11
    evm: 0


    Loading map: Maps\Menu\Castle_Forge_Map using template (none)
    Loading screen counter: 299 of total 300
    Timestamp: 3642146769697
    [ 2021/01/20 20:41:58: 853 ]ShutDown Network Engine.
    TMemoryVector - Total amount of leaked memory: 0 Bytes found.
    Share this post

  2. #2
    Can nobody even give me a hint what to do to fix this? Cant play this anymore because of this issue.

    Now I've reinstalled on one of the 2 machines, and the other is using a new laptop, still the same desync.

    Found 1 case where it did not desync - when I started a multiplayer game and built nothing as the 'guest' player, and built next to nothing on the 'host' - then it was fine, so maybe that explains something about the error, but it doesnt help me play it.
    Share this post

  3. #3
    Ubi-Ginge's Avatar Ubisoft Support Staff
    Join Date
    Oct 2018
    Sorry for our delay in getting back to you mritoldyouso
    Do you still find yourself getting desynced after going through the steps in this link?
    Share this post

  4. #4
    we are getting desyncs every other game as well.

    We are playing Settler 7 History Edition with UPlay. Both players are on the same LAN.
    Windows 10

    The tips from your link are not really helpful as they are supposed to fix LAN or connectivity problems. We don't have any connectivity issues here.
    I can't really understand how a game developer can implement such a possibility for a desync anyway. If it happens, the game should just copy the last state from one of the player and resync all players. This can't be so hard!

    Please fix this.

    Best regards
     1 people found this helpful
    Share this post

  5. #5
    Getting the same thing. I'm finding posts that the HE edition was diong this at release also.
    Why's a fix for this taking so long? The non HE editions worked fine, can yall hurry up with patching this or at least not give us links that don't provide any actual support ????
    Share this post

  6. #6
    Thank you for replying. I had tried all the steps in that faq without it helping. although not the port forwarding - it doesn't make sense to use it in a scenario where 2 machines on the same LAN...

    I gave up playing for a while, but, we have actually been able to play 2 multiplayer games in the last month without desync, although in the same time 10-20 games have desynced within the first couple of minutes.

    So I still dont understand what is the cause of the desyncs, I am starting to think it must be an issue with whatever servers ubisoft are providing to support multiplayer. It's a pity that's even necessary to have an internet based server really, since we're just playing LAN co-op for fun. I hope this will get fixed, because it's a fun game when it works..
    Share this post

  7. #7
    Same here, I bought the History Edition yesterday and tried to play with a friend WAN. Both games endet after ten minutes with a desync error. Custom victory point settings were only visible on the host system.
    Share this post

  8. #8
    Ubi-Gizmo's Avatar Ubisoft Support Staff
    Join Date
    Sep 2021
    Hey everyone, thanks for bringing this to our attention. Sorry to hear that you have been experiencing this issue on the History Edition. Who was the host of the game? If you were the host, could you please try a scenario where your friend hosts instead, and then you join his game/ vice versa? I would also recommend that you go through this connectivity troubleshooting article. It is a great way to help ensure both of your connections are optimal to the History Edition servers.

    For anyone experiencing the connectivity problems on The Standard Settlers 7 game, it is important to note that the online services have since been shut down. This might affect your ability to play multiplayer matches; alternatively, if attempted on a local network, I would recommend going through the article I mentioned earlier. I apologise for the inconvenience caused and hope this information helps.

    In the meantime, we'll continue to monitor things and look out for any issues on our side.
    Share this post

  9. #9
    Thank you for the reply, I was checking back here because we actually got multiplayer to work once a couple of times a few weeks ago, but then it has failed on the following 10 attempts, on different days

    Yes we have tried swapping hosts, and as said before we've gone through the steps in the help article without it making a difference.

    Seems like custom maps where we modify the number of victory points are far more likely (but not certain) to desync than others, and some standard maps like grassland mesa will desync after about 10 mins.

    I dont understand what kind of online services there are for this game, I noticed in the lobby that other online game sessions were listed. Doesnt affect our case as its LAN only. It really is too bad about this because its a fun game on the few times it works.

    Out of interest, what is it that you will you continue to monitor?
    Share this post

  10. #10
    Ubi-Milky's Avatar Ubisoft Support Staff
    Join Date
    Jun 2020
    Hello mritoldyouso, thank you for getting back to us.

    Is there any particular reason why you and your friend prefer to play over a LAN connection on the same network?

    The servers for the older The Settlers 7 game have been shut down, but the servers for the newer history edition of the game should be working as intended.

    Have you both tried connecting to our server separately instead and inviting one another to a game, whilst connected to separate networks with different routers?

    The reason I ask is that we are limited in what troubleshooting we can advise you for LAN connections, but if you have a problem connecting to our servers separately as well, this is something we can escalate over a support case.

    Can I also ask, are you using our up-to-date launcher Ubisoft Connect instead of our older launcher, Uplay? Sometimes using our older launcher can affect players connectivity and performance of our games, some games will also not launch at all f using our older launcher, but should prompt you to update to the latest, which can also be downloaded from our website > https://ubisoftconnect.com/en-GB/
    Share this post