🛈 Announcement
Greetings! Trackmania forums are now archived and accessible in read-only mode, please go to the new platform to discuss the game.
  1. #1

    No online access after adding custom blocks

    Hello everyone!
    I am a fresh player and ran into a problem yesterday, maybe you guys have experiences with this.

    I was building a map and wanted to add magnet-pieces.
    Went to trackmania exchange and got a magnet pack.
    Instructions were to create a folder called "Stadium" in "items" and then unpack the stuff there.

    Upon trying to restart the game i get some problems:
    • long loading time until start screen
    • no connection to uplay (can talk to friends tho)

    I tried to delete the folder I created again, reinstalled TM and Ubisoft Connect, but still cant play online anymore.

    Please help 🥲

    P.s.: i also get a log file in my "documents" that says something with "buddy.mode.dll" or something like that cant be found.
    I searched the internet already, but could only find people having problems with router, soundcard or having to unlink their switch account.

    P.p.s: posted in wrong forum section, sorry

  2. #2
    Fowst2010's Avatar Banned
    Join Date
    Nov 2010
    Posts
    238
    All I know about the custom block, is that it takes a lot of RAM.
    That means at least your loading time can be considered normal.
    Although I'm afraid I might not be too helpful here, any answer is better than no answer right? Here's 2 questions:

    Can you place the magnets in editor, validate the map etc?

    Can you just restart the game without the custom block, will uplay work then?

  3. #3
    Ubi-Thrupney's Avatar Ubisoft Support Staff
    Join Date
    Mar 2021
    Posts
    587
    Hey Dave, thanks for reaching out about this on the forums. Sorry to hear you've had trouble getting back into the game after adding a custom block. Let's see if we can get this sorted for you

    Did you re-add the custom block after reinstalling? Please try just validating the files, rather than outright reinstalling. You'll find instructions on how to do that in our troubleshooting guide. Please also check our connectivity guide, and do the resetting network hardware and checking for conflicting software steps.

    If it still doesn't work, please let me know, and I'll have some further steps we can try.