🛈 Announcement
Greetings! Anno forums are now archived and accessible in read-only mode, please go to the new platform to discuss the game
  1. #1

    Bugs in campaign expeditions

    During the contract expedition if you chose to search the study then the assembly hall (only in that particular order) the game tells you that you've found a fossil but no reward is actually given.
    Spoiler:  Show

    The map in Arctic expedition has a duplicate icon for Ivujivik.
    Spoiler:  Show
    Share this post

  2. #2
    Ubi-Thrupney's Avatar Ubisoft Support Staff
    Join Date
    Mar 2021
    Posts
    595
    Hey fissilecore, thanks for your post about this! I really appreciate it, as I'd like to get this looked into.

    For the first issue, can you tell me what the expected reward would be for the fossil? I don't have the game to hand myself at present, and I want to make sure I'm reporting the correct information onwards for us to investigate.

    For the second, please make sure you've had a look at our troubleshooting guide, and made sure to follow the verifying your game files steps, and updating your graphics drivers and OS. This makes sure that all your files are up to date and definitely not corrupted, so we know that isn't causing this graphics glitch. Let me know if this doubling issue persists with this icon thereafter. Thanks!

    Let me know if I can clarify either of these requests, and thanks once more for your help.
    Share this post

  3. #3
    Firstly, I verified all the files and tried running the game in different APIs and differrent resolutions - it made no difference. My GPU drivers and Windows are up to date.
    About the first issue: to recreate it you have to chose play it bold (success) then frontal assault (success). The first room you open always rewards you with protoceraptors egg. If the second room is study you will get this reward:
    Spoiler:  Show

    If the first room is library and second is assembly hall you will get this:
    Spoiler:  Show

    So the reward from the assembly room is different depending on the first room you choose. It was most likely meant to be the fossil from the first picture.
    Now about the second bug - upon discovering Ivujivik for the first time the icon for it will actually be correct:
    Spoiler:  Show

    But if you open the map any time during subsequent expeditions it introduces a duplicate.
    P.S. I've found some additional inconsistencies while trying to replicate the first problem with different choices. When you go with the crafty route you will be asked to say a password. It will prompt a slide with 3 different options. If the correct option (Diosa) is second in the list, the next slide will have some text in bold:
    Spoiler:  Show

    But if it's first in the list, all text will be uniform:
    Spoiler:  Show
    Share this post