🛈 Announcement
Greetings! The Rainbow Six Siege forums are now archived and accessible in read-only mode, please go to the new platform to discuss the game
  1. #1

    Says i don't own rainbow on ubisoft connect, but i have on steam

    i tried playing rainbow and it won't launch it just pops up with "starting game, this will bind the following products to ur account" and so i tried to push ok and it didn't work it said "there was a problem authenticating ownership of this product", and so i tried going to ubi connect and it said i didn't have any games.
    Share this post

  2. #2
    and it's that same for all my ubisoft games they just up and disappeared
    Share this post

  3. #3
    Ubi-Thrupney's Avatar Ubisoft Support Staff
    Join Date
    Mar 2021
    Hey UwUrixu, welcome to the forums - we'll be happy to help with that!

    This is something which happens when you've got the games activated on a different Ubisoft Connect account than the one you're logging into. As such, it's likely these Steam copies were already activated on another account. Do you have any other Ubisoft Connect accounts you can try logging into?

    If you can't find the correct account, or if you're sure you didn't have one, please get in touch with us through one of our direct channels (since we'd need to look more closely at your account, which we can't do here on the public forums). Any of the contact methods below are fine

    Facebook PM
    Twitter DM
    support website

    Let me know if I can clarify this further, or if you have any trouble getting in touch via the links above!
    Share this post