🛈 Announcement
Greetings! The For Honor forums are now archived and accessible in read-only mode, please go to the new platform to discuss the game
  1. #1

    Stuck on Domination Load Screen

    When I load into a domination game, I get stuck on a black screen just before character select. I still see people joining and leaving the session and the text channel works but it just never loads into a game. Forcing me to quit the game and restart. This is quite frustrating.

    Share this post

  2. #2
    Ubi-Litten's Avatar Ubisoft Support Staff
    Join Date
    Oct 2018
    Posts
    2,021
    Hi there, thank you for providing this information and sorry you are experiencing this issue while launching the Dominion game mode.

    So we can investigate this further could you please confirm whether this is the only mode you are experiencing this in?

    Also, while I understand you may have already attempted some of these steps, could I suggest working through this article.

    If you are still receiving this error after completing these steps, could you please update us with your system specifications and we will be sure to get this looked into further.
    Share this post

  3. #3
    I have the same issue ( now I got 2 bugs at the same time, yay...). At first I thought it is server issue about two weeks ago. But yesterday it kept happening in dominion until I rebooted my whole system.
    Share this post

  4. #4
    Domination is the only mode where I experience this issue.
    Share this post

  5. #5
    I have the same issue ( now I got 2 bugs at the same time, yay...). At first I thought it is server issue about two weeks ago. But yesterday it kept happening in dominion until I rebooted my whole system.
    Share this post

  6. #6
    ubi-smash's Avatar Ubisoft Support Staff
    Join Date
    Sep 2019
    Posts
    1,135
    Hey folks, sorry to hear this is only happening in Dominion Mode. To gather some further information, could you tell us what your NAT type is currently before entering if this happens when grouped with any friends in your team, solo, or if this has happened in both scenarios?
    Share this post

  7. #7
    Solo only and with green NAT
    Share this post

  8. #8
    UbiStorm's Avatar Ubisoft Support Staff
    Join Date
    Jun 2020
    Posts
    193
    Thanks for confirming that for me, Iskarioth.! Would you also grab a short video of this issue happening for me?
    Share this post

  9. #9
    It looks exactly like the screener that was posted at the top - black screen saying dominion and showing names of players joind and failing - but it didn't happen all week for me
    Share this post