🛈 Announcement
Greetings! The For Honor forums are now archived and accessible in read-only mode, please go to the new platform to discuss the game
  1. #1

    (Micro)-Stuttering/System slowing down

    So, back in April, I started For Honor and suddenly the game started stuttering overnight without changing anything on my side. Even my System is getting slow and unresponsive while the game is running. Not a pleasure if you want to multitask. Temps and GPU/CPU usage are looking okay.
    To the stuttering. It's not an occasional stutter like I see it mentioned in other threads, it's a permanent jaggy, stuttering. The framerate is still good, but worse than before the problem occurs, it's even going down in the low 60's which is unusual for me. It's just not smooth and enjoyable to look at. Sometimes when a match is starting, it's fine for the first minute of the match, but then the stuttering is starting again. Rarely, but it happens, the game is running fine for a few seconds in a match. I even had the scenario that the game was running fine for a few seconds after I changed some random settings like the controller input. And no, using mouse and keyboard makes no difference.


    Of course I got in contact with the support and it took a few weeks for the support and me to narrow down the problem. I tried absolutely everything, going from sending video footage of the problem, to reinstalling the game, verifying the game files, doing a clean driver un- and install, using specific graphics/monitor refresh settings, using just one monitor instead of two, doing a clean windows boot, creating a second Windows user profile, disabling "HPET" and probably some other things which I cannot remember at this moment.
    In the end, Support told me, that he has to send this problem to the For Honor devs. As soon there is new information regarding the problem, they will post it on the forum. Something like that.

    Now I want to ask if anyone else got this problem? And if so, have you fixed it somehow?
    I think the problem is not on my side, but of course I can't be 100% sure.
    Share this post

  2. #2
    Ubi-Mark.'s Avatar Ubisoft Support Staff
    Join Date
    Nov 2017
    Location
    Base of Operation
    Posts
    6,899
    Hello Gwynbleidd2707, welcome to the forums!

    Sorry to hear about your experience.

    This sounds like an isolated instance related to your specific computer's configuration that has to be looked into by the development team. Can you please provide us with your case number, so we can have a look?

    Many thanks and if you have any other questions, please let us know.
    Share this post

  3. #3
    Hello, sorry, took a while, but sure, here you go: 14559478
    Share this post