🛈 Announcement
Greetings! Anno forums are now archived and accessible in read-only mode, please go to the new platform to discuss the game
  1. #1

    Scholar Housing

    After the new Tourist season download, all of my Scholar residences dissappeared. I had hundreds of scholar houses and they are gone. My statistics tab shows no scholars. I cannot build new scholar houses as there is no button on the building tab. I researched for building permit and still no luck.
    Share this post

  2. #2
    Takarazuka15's Avatar Member
    Join Date
    Apr 2011
    Location
    United States
    Posts
    76
    Originally Posted by Phaedra12 Go to original post
    After the new Tourist season download, all of my Scholar residences dissappeared. I had hundreds of scholar houses and they are gone. My statistics tab shows no scholars. I cannot build new scholar houses as there is no button on the building tab. I researched for building permit and still no luck.
    I replied on another post you made with this same issue but I'll also comment here in case anyone else sees this and has the same issue...

    This was due to an update that was needed in the spice it up collection. The mod was updated shortly after release but if you didn't go and check to see if the mod needed updating before you loaded your save game after the patch then you're kind of out of luck. The most you can do is update your mods, something you need to be doing every time there is a patch and never load the game until you do so, and then reload a save before The patch went live.
    Share this post

  3. #3
    Thank you for the answer, I had started to work that out. I should have checked, but I became confused with the time difference. I opened the game on the 26th and it updated automatically. The joys of being a day ahead of the majority of the world.
    Share this post

  4. #4
    Could U please explain what U did to make it work again. I understand that I have to update my mods. But I allready have Spice it up 3.0.4, and I don´t see any newer version on Nexus. What am I doung wrong....Or what is it that I´m NOT doing :-)
    Share this post