1. #1

    Here we go again. BLACK SCREEN

    I've seen many posts on this subject and it seems most dont have the correct specs for the game to work. I know you need quad cores and i have 6 cores.
    I've tried most things i've found and it whould be nice to play the game i paid for.

    CPU: Intel(R) Core(TM) i5-8400 CPU @ 2.80GHz 2.81 GHz
    16GB RAM
    NVIDIA GeForce GTX 1060 3GB
    Windows 10 64 bit
    Share this post

  2. #2
    WID992007's Avatar Senior Member
    Join Date
    Sep 2007
    Posts
    2,234
    its not your hard ware

    make sure you installed the updated version of UBI connect
    you can get that here
    https://ubisoftconnect.com/

    i also use an i 5 7600 K and a GTX 1060 (i have the 6 gig model tho )

    game runs perfectly fine > what vid driver do you have installed >? .. have your tried a clean install of an older driver yet >?

    do you have a STEAM copy ?

    if so get Steve 64B's reg fix .. to see it that's the issue

    https://forums.ubisoft.com/showthrea...1#post15014109

    if you have a steam copy it could be ,

    Most likely due to the error with the STEAM version of the far cry 4 map edit program , STEAM broke it back in early 2019
    to fix it, yes you will need to edit your system registry and remove a bad entry that STEAM created, as well as UNINSTALL, then reinstall possibly the Uplay launcher and Quite possibly your FAR CRY 4 game ???
    below is a few links for the information on how to fix it .

    or try STEVE64b's reg fix .zip < best quick fix ! STEVE ROCKS


    BACK UP YOUR SAVE FILE FIRST ..that information is also listed in the tips section on steam on how to do this step
    or look here
    https://support.ubisoft.com/en-GB/fa...ay-save-files/
    Save Game Locations for Far Cry 4:
    UPlay PC. C:\Program Files (x86)\Ubisoft\Ubisoft Game Launcher\savegame\<UplayID>\420.
    Steam. C:\Program Files (x86)\Ubisoft\Ubisoft Game Launcher\savegame\<UplayID>\856.


    (*Note the Uplay only version of Far Cry 4 does not have this PROBLEM .only the STEAM version of the game seems to have an issue with the far cry 4 map edit program )
    PLEASE see the TROUBLESHOOTING TIPS section PINNED TO THE TOP OF THE FORUMS ON STEAM , as that info about the problem and the fix , has been posted there for over 1 year


    see these links to other forums posts on the issue, to fix it on your PC


    https://steamcommunity.com/app/29811...0856106568287/


    see also
    https://steamcommunity.com/app/29811...4964985644034/
    https://steamcommunity.com/app/29811...0247641982223/
    https://steamcommunity.com/app/29811...6410443376001/
    https://steamcommunity.com/app/29811...0678162154886/

    https://forums.ubisoft.com/showthrea...1#post15014109


    Additionally, for other issues you may wish to look into, that may be the cause of your problem ...


    Please see the Ubisoft Support Troubleshooting page here and please go through the steps provided
    https://www.ubisoft.com/en-gb/help/c...n-pc/000061047


    If you still have an issue, Please Contact Ubisoft Support Directly.
    you can do so from that above LINKED page .. or here...to open a support ticket / case

    https://support.ubi.com
    Share this post