1. #1

    Issue with dedicated server

    Hello,

    I am currently trying to setup a dedicated server to play with my friends. As it worked pretty well on TM², I used nc1.eu as host for my server.

    Sadly I can't connect to the server and the game says that the server hasn't been updated to the last version.
    So, I tried to search how to update it but I couldn't find anything.

    I was wondering if someone could help me here ^^

  2. #2
    Ubi-Alinoa's Avatar Super Moderator
    Join Date
    Feb 2010
    Posts
    748
    Hi,

    You can find information here: https://forums.ubisoft.com/showthrea...1#post15449997

    Cheers

  3. #3
    Thank you for your quick answer,

    I have already seen this thread and the tutorial associated with it. But it didn't seems like this fits to the kind of server I'm using. What I mean is that when I check my server files on nc1.eu there is not any "TrackmaniaServer.exe" file for instance. Thus, I really don't understand how to update it.

  4. #4
    Originally Posted by Ubi-Alinoa Go to original post
    Hi,

    You can find information here: https://forums.ubisoft.com/showthrea...1#post15449997

    Cheers
    There are 2 different files in the post that differ by date. Which one is correct?

    Both options are not running. The system swings to "Invalid statement." The server startup string is as follows:
    Code:
    ./TrackmaniaServer /game_settings=MatchSettings/tracklist.txt /dedicated_cfg=dedicated_cfg.txt /nologs
    The previous version of the server runs smoothly. Only a game on such a server does not allow. System:CentOS 8.3.2011

    https://forums.ubisoft.com/showthrea...dicated-Server Why shut down this discussion? Now will we produce dozens of new topics about the same non-working server?

  5. #5
    The server version, changed on 06.12.2021, appeared on the link http://files.v04.maniaplanet.com/ser...ver_Latest.zip But it does not start, the same error:


    The latest working version of the server is from 04.08.2021. But the game swears at the outdated version.

    I continue to observe...

  6. #6
    As far as I understand, the assembly of the latest versions used what is not in my system. How can I know the minimum requirements for running a Linux server?