1. #1

    Game freezes and lags since last update.

    Hello

    Hadn't played Anno for a few weeks but wanted to play yesterday(10/2). The game downloaded an update and nothing weird there. But when i started the game it keept freezing and lagging no matter what i did. Klicked on a ship, on a building, changed to another area. It would run smothly for maybe 20 seconds and then freeze again for about 7-8 seconds. Ive tried updating my graphics card(Nvidia Ge-Force), both newest version and and old version(457.51).

    I have read the thread regarding the game freezez with some newer graphic versions. That doesent apply to my problem. I didnt do anything to my computer or graphics card before downloading the recent game update. Before the recent game update the game worked fine so its not my computer, it all started with the newest game update.

    I cant be the only person having this issue!? Please advice.
     20 people found this helpful
    Share this post

  2. #2
    Me Too.i look at task manager Anno use 100% memory.plese fix it.
     2 people found this helpful
    Share this post

  3. #3
    After the update the game starts to become not playable anymore. The lag is really unbearable. I just shut down the game after I needed to wait a 10 to 20 seconds for each handling with the mouse. Switching sessions became a disaster (you need to watch a blue screen before changing.)
    I already tried to change from directx 12 to 11, but it didn't work. Most of the times it solves the problems.
    It looks like the same problem after the Land of Lions update.
    It is really frustrating when I read in the release notes of GU9.3 in the bug fixes this 'Fixed an issue with reduced performance...'
    It rather destroyed the performance.
     1 people found this helpful
    Share this post

  4. #4
    Omg the same thing is happening to me. In the spanish forum they just say: send a ticket, but i cant even connect to the servers. Hahaha i cry. I have been playing the last weeks a lot without any problems. Now the game freezes for 30 sec or more ..... Atleast i can use the rewards from ubisoft club now ¬¬
     1 people found this helpful
    Share this post

  5. #5
    Try setting Viewing Distance to Low.
    It helps with the lag. Seems that there is a bug with rendering unnecessary / invisible details.
     1 people found this helpful
    Share this post

  6. #6
    Same problem here. DX11,32 GB RAM, RTX 3080.

    The game was running perfectly 2 days ago...
     1 people found this helpful
    Share this post

  7. #7
    Ubi-Thorlof's Avatar Anno Community Developer
    Join Date
    Apr 2018
    Posts
    650
    Hey all, the team is currently investigating this issue.

    Could you please let us know if the issue only appears when you're actively doing something (e.g. clicking) or even if the game is just running on its own without you doing anything? Thank you!
     3 people found this helpful
    Share this post

  8. #8
    That's "normal", the game will use up to approximately 24GB's according to people who have 32GB's of RAM. On my system with 16GB's of RAM, this game uses all available RAM the instant it finishes loading my Save Data.
    Share this post

  9. #9
    Originally Posted by Ubi-Thorlof Go to original post
    Hey all, the team is currently investigating this issue.

    Could you please let us know if the issue only appears when you're actively doing something (e.g. clicking) or even if the game is just running on its own without you doing anything? Thank you!
    Hey there, I currently have this problem in a multiplayer session with a friend, there's also Bente and Gasparov in the game with us.

    I am the one hosting and it basically happens every time my friend is clicking on a building or on the mini-map to get the camera elsewhere. It's not a one time thing either, the same building can make the game freeze if it gets clicked again later.
    As the host, it also happens that creating/upgrading buildings at once makes the game freeze for multiple seconds. The more buildings are created/upgraded, the bigger the chance for a freeze.

    Usually after 15-20min the game freezes to the point one of us gets "disconnected, the game is offline" which kicks the other from the session.
    Share this post

  10. #10

    Same issue

    I am having the same problems with the freezing and lagging, mine doesn't just do it when clicking buildings though. When I pan the game gets stuck and pans across half the map before I regain any control. As it is right now the game is barely playable. I had no issues with the game before the February 9th update.
     4 people found this helpful
    Share this post

  11. #11
    Had this problem as well it was working perfectly fine before the update after the update the game freezing for few sec then continue and sometimes freeze again. I'm in sandbox mode
    Share this post

  12. #12
    I didn't manage to pinpoint/reliably reproduce the issue, but it occurs to me as well.

    Maybe it's coincidence, but many times I was switching to another tool (e.g., build/destroy/move/upgrade) when the freeze occurs. But no clear pattern.

    However, the world map seems to lag quite a lot.
     4 people found this helpful
    Share this post

  13. #13
    Same here, can hardly move over the map since 2 days and not able to do a thing. Loading the game takes age as well now.
     4 people found this helpful
    Share this post

  14. #14
    Try setting Viewing Distance to Low. This helped for me when i use the full zoomed out Cam its normal. For me. And one other Person had the same Problem as it seems.
    Share this post

  15. #15
    Since 9.3 this game is unplayable for me and i have only 175k overall Population. Please fix. Before 9.3 everything was fine!
     1 people found this helpful
    Share this post

  16. #16

    A Bit More Detail

    RTX2080Ti, 16Gb Ram. 2k resolution.
    Everything on max settings, DX12

    1. Random Stuttering (No FPS drop reported from the in-game fps counter, 100fps feels like 20)
      Mostly when trying to place buildings in production clusters. Residential districts appears to be less affected (Much more noticeable in the Artic Region)
    2. Micro-freeze
      Clicking on warehouse / trading post is the most common, although it does happens on other random occasions


    Memory usage was through the roof (I am not sure what it is before GU 9.3 though).

    Issue 1 does get better when zooming out to max range and / or tuning down the viewing distance. Something to do with rendering incorrect / invisible objects?
    Issue 2 is just there no matter what I did
     2 people found this helpful
    Share this post

  17. #17

    Fix this ****

    At least give us the oppertunity to reverse the last update. Game worked fine before the last update.

    FIX THIS ****
     1 people found this helpful
    Share this post

  18. #18
    Same issue here. Everything was fine a few days ago, now since 9.3 it takes way longer to load the game and it is unplayable even on low details. After two hours of triying to get it to run I give up
     1 people found this helpful
    Share this post

  19. #19
    for me too...
    its dragging like a cowboy stuck in the stirrup
    nearly everything i click i get a loading cursor, if i click a second time the game freezes. sometimes clicking doesn't grab the item i am clicking. changing regions and opening the Research Institute freezes for ages...and i don't mean seconds...the game still takes forever to load, after clicking the blue play button my computer goes mega slow and it is ages before the next screen (epilepsy warning) and then the play game screen pops up...from clicking the play button to actually getting into the game can take 20 mins or more...time enough to get bored with the waiting and do something else but instead you have got me addicted to staring at the spinning circle of doom cursor.
    and...it isnt mods....OR my mouse.
    Share this post

  20. #20

    Over a week

    Mine has been doing this for about 10 days now and it started one even when I loaded up my game. The file wasn't any bigger, my graphics card hadn't updated so it was none of those issues. Lagging when I move around. Lagging even, on the load screen. Freezing up. I haven't played in several days because it has become unbearable. I just went in it again & it is even worse now. I have switched to DX11 & that didn't even help.

    Just thought I'd chime in too.
    Share this post

  21. #21
    Asterix201252's Avatar Member
    Join Date
    Jul 2016
    Location
    Dorset
    Posts
    235
    Same for me too. Lags and stutters since 9.3.
    RTX2060 SUPER, DX12
    Share this post

  22. #22
    Originally Posted by Ubi-Thorlof Go to original post
    Hey all, the team is currently investigating this issue.

    Could you please let us know if the issue only appears when you're actively doing something (e.g. clicking) or even if the game is just running on its own without you doing anything? Thank you!
    I just tested zoomed at maximum, looking face down on an empty grass island, not doing anything. And I still had the freeze for a few seconds. So it doesn't seem to be caused by user input.

    Alsoooo, I managed to isolate the issue It happens right before an automatic save (i.e., when the cogs in the top-right start spinning). So by default it happens every 5 minutes.


    I managed to take two videos (one after another) of the issue AND here's a sample savegame which reproduces the issue.

    How to reproduce:
    1) load game
    2) make sure the "Autosave interval" is set to 5 mins to reduce waiting time
    3) wait 5 minutes
    4) freeze happens, and one can see that settings cogs icon start to rotate

    Savegame: https://drive.google.com/file/d/14fa...ew?usp=sharing
    Video of freeze 1: https://drive.google.com/file/d/1nCv...Gudjon/preview
    Video of freeze 2 (5 minutes after the previous one): https://drive.google.com/file/d/1gr3...6pj_Rs/preview
    Share this post

  23. #23

    Game Freezing

    Windows 10 has updated few days ago and now my game would freeze at random instances but always as the result of my action. On the first day after Windows update the the game was freezing frequently for 30-60 sec in the beginning. Later it would freeze for 20-40 sec every 15 to 20 minutes.
    Share this post

  24. #24

    No issues until...

    I started a new game & had no issues until I discovered the New World. Now it's almost unplayable. 4k population, 16Gs of memory, good graphics card. I had almost every other program on my computer shutdown & when I checked the memory, it's at 96% usage. I shouldn't be having these issues with the setup I have.
     2 people found this helpful
    Share this post

  25. #25
    It certainly is from doing stuff. Jumping between worlds, using the minimap to jump around, selecting a town hall or trade union, or similar. It freezes for about 10 seconds. The exact same save (world population 48,000) did not have that issue prior to 9.3
    Share this post

  26. #26
    wezu21's Avatar Junior Member
    Join Date
    Feb 2021
    Posts
    10

    The wors thin is...

    The worst thing is, everything starting happen after update which was directly connected with new content. Ubisoft you add to my computer files needed to play in new season pass 3 features which i didn't buy and because of this you broke, game which i already buy.

    Why ??

    For the cash, of course, that the potential customer, after buying new add-ons, would say "how quickly did I buy and now I can play"

    This is very bad practic form me.If anyone tested this new patch before you released it?
     1 people found this helpful
    Share this post

  27. #27
    Is there any official communication out already that this is going to be fixed? Or is playing this game over?
     2 people found this helpful
    Share this post

  28. #28
    For me it happens all the time. No matter what im doing. Building, paning, clicking. It doesnt matter what im doing, it still freezes/lags. I saw someone posting that it only happened like every 5min for them when the game was autosaving. That does not apply to my problem, as i posted above.
     2 people found this helpful
    Share this post

  29. #29
    Same here, started a new game after uptade 9.3. Everything was running smooth like normal and it freezes the moment I discovered the New World...
     1 people found this helpful
    Share this post

  30. #30
    https://www.youtube.com/watch?v=KL_DjDsg7I8

    Dont know if its the same Problem you Guys are having but i think it might be the same Lag Issue. Trying lower Texture Qualitys seems to help. Until its solved. (Or Distanz View Medium)
     2 people found this helpful
    Share this post

  31. #31
    Ubi-Thorlof's Avatar Anno Community Developer
    Join Date
    Apr 2018
    Posts
    650
    Hey all, sorry for the current performance issues with Anno 1800.

    Our team is currently investigating this issue and we'll let you know when we have news.
     3 people found this helpful
    Share this post

  32. #32
    My current game with almost 20k houses is barely moving from just loading in 9.3, while in 9.2 it was doing fine.

    Share this post

  33. #33
    I had the exact same issue as described here, I could hardly play the game. Everytime I performed any action the game could freeze.

    However, today I coincidentally received my new memory stick, which increased my memory from 8gb to 16gb. And now the game is running absolutely perfectly. So seems to be an issue with memory.

    Don't know if this helps, but thought I would share it.
     1 people found this helpful
    Share this post

  34. #34
    This seems to be in the wrong thread. FPS drops due to memory are not the reason for the issues above.

    Originally Posted by Geertos38 Go to original post
    I had the exact same issue as described here, I could hardly play the game. Everytime I performed any action the game could freeze.

    However, today I coincidentally received my new memory stick, which increased my memory from 8gb to 16gb. And now the game is running absolutely perfectly. So seems to be an issue with memory.

    Don't know if this helps, but thought I would share it.
     2 people found this helpful
    Share this post

  35. #35
    this happens when i'm in any of the collection screens (zoo, museum etc) now and than. at least it's not a CTD that's much worse.
     1 people found this helpful
    Share this post

  36. #36
    I got the same lag/freeze problems after the 9.3 update. The game in general is sluggish and underperforming with frequent input freezing. Every minute or so the input handling gets stuck and the same signal is active during the whole freeze. For example: during panning the handling freezes and the game is stuck panning for several seconds.

    Another thing that makes the game a slideshow is looking at Hunting Cabins. The closer the camera gets to a cabin the worse the frame drop becomes. I have a big cluster around a union and just by looking at it makes the game a slideshow. No other factory cluster has this issue.


    PC specs:
    Ryzen 5 1600, 32GB RAM, AMD RX 580 8GB.
    All drivers and Windows 10 are kept up to date.
     1 people found this helpful
    Share this post

  37. #37

    Lag since last update

    You are not.
    Same problem I had not before.
    Running i9-9900K rtx3090 all updated
    I wont tell my game setup since it s the same I had before patch.
    Share this post

  38. #38

    same problem

    same here, nothing helped. please fix it ASAP. I couldn't even start the Land of Lions missions yet
     1 people found this helpful
    Share this post

  39. #39
    had same issue since update, even when left alone game constantly freezes/unfreezes every few seconds. Pretty annoying no fix yet considering DLC is so close...
     1 people found this helpful
    Share this post

  40. #40
    I have the same problem. It stops me from playing the game.
     1 people found this helpful
    Share this post