🛈 Announcement
Greetings! Trackmania forums are now archived and accessible in read-only mode, please go to the new platform to discuss the game.
  1. #11
    Armo_Nix, ok so the problem you describe is the exact same as mine ! I imagine you're not playing on geforce now ?

    Tona, the issues we're describing don't seem related to the one you're talking about. They happen randomly, approximately one out of two times at any point of the day. They don't seem to affect other players.

    What is curious is that I used to have this exact problem with the review server until a few weeks ago, but now it's all fixed.

  2. #12
    This isn't fixed yet... Please do something, this is my favourite mode of the game but i can't play it cause of this problem.

  3. #13
    I don't know if you guys have figured out a fix for this yet. But I've been getting the "couldn't connect to server error" most times I try to connect to COTD or Track review. I did notice that if I join a previous Track of the day or download a new track I get in more often. It's kind of weird connection between the 2 but it kind of works. Hopefully this helps figure out what's wrong. This bug is really annoying and I hope it gets fixed soon.

    Forgot to mention I'm using geforce now

  4. #14
    I experience the exact same problem. I tried the free version to see if it worked with Geforce Now before upgrading to a subscription. Is it the same outside the matchmaking?

  5. #15
    I'm dealing with the same issue. Is there any update on that? Like 3 of the last 4 days I was not able to connect to the server after the COTD qualification. I also got this issue when I tried to connect to the qualification server first, but it worked on second try. (That's usually works on second or third try if I get the error.) However I was not able to proceed to the COTD server after the qualification, doesn't matter how many times I tried. I even left the qualification server and rejoined but the error persisted.

  6. #16
    Ubi-Thrupney's Avatar Ubisoft Support Staff
    Join Date
    Mar 2021
    Posts
    595
    Hey everyone, thanks for keeping us updated on this. These disconnects are very unusual - we've not had any reports of persistent problems such as these.

    @BigBraveGiraffe - can you confirm if you're also connecting through GeForce Now?

    @Armo_Nix - same question, were you on GeForce Now?

    @Everyone - does any of you happen to have recorded footage of this error happening? Or has the means to do so? This would be most helpful in our investigations.

    Thanks again for the help, and for your patience with this - it'll be great to get this sorted

  7. #17
    Hi,

    Yes, I use GeForce Now to play the game. In the last couple of days the situation was better, so I was able to connect to COTD right away, thus, couldn't record the error.
    But I recorded the same error as I tried to connect to the actual TOTD server (the morning after the COTD ended):


    Also, I got the issue during ranked when I tried to join the game:

  8. #18
    Yesterday I managed to record something:


    After the COTD qualification there were several unsuccessful connection attempts until I was finally able to join the game.

  9. #19
    The problem is still going there isn't really a way to fix that? It is so frustrating, i'm would like to play even gamemods i'm paying for xD

  10. #20
    Ubi-Thrupney's Avatar Ubisoft Support Staff
    Join Date
    Mar 2021
    Posts
    595
    Thanks for reaching out about this, presyNA - I can certainly understand that you'd want to be able to access a game you've purchased, and I've contacted our teams to see where we are in getting this investigated. Sorry for the inconvenience in the meantime.