1. #1

    FPS drop when having selected any of the buildings/ships/etc in a big city.

    I am experiencing FPS drop when having selected any of the buildings/ships/etc in a big city (GUI). After deselecting the FPS go back up. Or with another words by having any of the UI window open in a big city the FPS go down. Very strange and I cannot solve this issue. Does anybody have a fix for this pls? Because the game runs fine except for this issue. Thank you
    Share this post

  2. #2
    After further research Iīve found out that only the GUI (buildings windows / frames with animated background like workers, investors or gear wheels of working buildings) are the culprit of the FPS drops.Every other frame without any animation doesnīt drop the FPS. Which is weird because the game runs pretty smoot when not having selected somethingh. I have Nvidia 2070 Super.
    Share this post

  3. #3
    Does this also occur with DX11? Are your drivers and everything up to date? Did you try to repair the game etc etc etc?
    Share this post

  4. #4
    Ubi-TheBerry's Avatar Ubisoft Support Staff
    Join Date
    Jun 2020
    Posts
    2,165
    Originally Posted by p6****a Go to original post
    I am experiencing FPS drop when having selected any of the buildings/ships/etc in a big city (GUI). After deselecting the FPS go back up. Or with another words by having any of the UI window open in a big city the FPS go down. Very strange and I cannot solve this issue. Does anybody have a fix for this pls? Because the game runs fine except for this issue. Thank you
    Hey there,

    Please give the steps in our guide a try.

    May we also know what your in-game settings are currently running to and has changing any of these made any changes?

    Thank you!
    Share this post

  5. #5
    I am using DX12. Meantime Iīve found out that going back to the Nvidia drivers 457.51 AND activating Vsync in the game NOT with Nvidia Inspector has fixed this odd issue. Itīs muuuuch better now. There is like tiny FPS drop when jhaving selected some building but itīs waaaaay better and smoooth. Also the whole performance has improvved...
     1 people found this helpful
    Share this post

  6. #6
    Ubi-WheelyDuck's Avatar Ubisoft Support Staff
    Join Date
    Jun 2020
    Posts
    1,210
    Originally Posted by p6****a Go to original post
    I am using DX12. Meantime Iīve found out that going back to the Nvidia drivers 457.51 AND activating Vsync in the game NOT with Nvidia Inspector has fixed this odd issue. Itīs muuuuch better now. There is like tiny FPS drop when jhaving selected some building but itīs waaaaay better and smoooth. Also the whole performance has improvved...
    It is fantastic to hear that you have found a solution that works for you!

    If ever we can help in the future just let us know
    Share this post