1. #1

    Anno 1800 DirectX Error- An unexpected directx error occurred present failed!

    I start playing the game and after 5-10 minutes, my game crashes and gives this error.

    -Windows directory is up to date

    -My DirectX driver is up to date

    -My screen card is up to date

    I guess it's not about me, how is this solved?
    Share this post

  2. #2
    the main issue is directX, try switching directX11 (it wont stop the crashes, but you shouldnt have as many.)
    Share this post

  3. #3
    Some up to date graphics card drivers on some graphics hardware cause problems. I would try switching to DX11 and if that does not work trying an older driver (half a year older or more)
    Share this post

  4. #4
    m using DirectX-12 11 fixes the problem?

    Is there any solution regarding this issue?
    Share this post

  5. #5
    Ubi-Karl's Avatar Ubisoft Support Staff
    Join Date
    Oct 2018
    Posts
    2,843
    Hey AdaletNamluda55, thanks for getting in touch and I am sorry to hear about this.

    I can confirm that this issue has been brought up by a number of players and as it stands, it is currently being investigated by our development team.

    For your future sessions of gameplay, make sure that you run the latest version of your video card driver and try to run the game in DirectX11.

    Apologies for the inconvenience this is causing and thank you for your patience in the meantime.
    Share this post

  6. #6
    Having same problem. Changing config to DirectX 11 makes no difference. The game is unplayable currently and crashes to deskop after 2/3 minutes. All drivers/directx/windows updates fully up to date.
    Share this post

  7. #7
    Ubi-Raziel's Avatar Ubisoft Support Staff
    Join Date
    Jan 2019
    Posts
    4,057
    Originally Posted by scoutsa Go to original post
    Having same problem. Changing config to DirectX 11 makes no difference. The game is unplayable currently and crashes to deskop after 2/3 minutes. All drivers/directx/windows updates fully up to date.
    Hello!

    Just to confirm, are you still receiving the same error since making the config change, or are you facing a different error now?

    If editing the config file does not work, try deleting it. That should reset the file to default settings as DX11.

    Here you go: %userprofile%\Documents\Anno 1800\config\engine.ini
    Share this post