🛈 Announcement
Greetings! Ubisoft Connect forums are now archived and accessible in read-only mode, please go to the new platform to discuss the game
  1. #1

    Despite apparently being "resolved", I still cannot use the Jump-In rule on Stadia

    Hey all,

    I bought Stadia a while back and decided to stop using it as it was a train-wreck at the time. One of the big issues was that whenever me and some friends tried to play Uno, none of us could activate the Jump-In rule despite all of us paying extra solely to get that feature. Ultimately we all just stopped our subscriptions and cut our loses.

    Just prior to Christmas I had seen a few reviews on how Stadia had improved and tried it again but this time for the whole family. I thought Uno would be a good game for the family to play, so I bought Uno Ultimate Edition again due to using the family Google account and to my bewilderment, Jump-In is still locked despite Ubisoft Connect telling me I own it and me paying extra just for it! It's been 2 months for something this simple to be patched, I know COVID-19 has slowed everything down however when you have customers paying extra, especially around Christmas, you think it would be a priority to ensure it has actually been patched.

    With the Support system telling me to "choose another support method", yet not naming any other methods at all, I was hoping that anyone here might be able to help solve this. I have seen various other posts on other forums about this, yet most of the Steam ones end in the cookie cutter "We are looking into it" with no real solution response from Ubisoft's PR.
    Share this post

  2. #2
    UbiExcellent's Avatar Ubisoft Support Staff
    Join Date
    Sep 2019
    Hi BobthePilot123 and warm welcome to the forums! I'm sorry to hear that on two separate occasions, you and your friends have not been able to activate the Jump-In rule in Uno. I completely understand how frustrating this must be, and am extremely sorry for the difficulties caused! Please send over a screenshot or provide a video link that depicts the Jump-In rule being locked, but also shows it as owned if possible please.
    Share this post