🛈 Announcement
Greetings! Ubisoft Connect forums are now archived and accessible in read-only mode, please go to the new platform to discuss the game
  1. #1

    Ubisoft Connect causing performance degradation on all Stadia Ubisoft games?

    Hi. I posted about this in the Watch Dogs Legion forum, but I think this is probably a better place for it.
    I've noticed that, across every Ubisoft game I have on Stadia, they will all start to suffer from performance deterioration (frame-rate dropping) after a prolonged play session.
    Its more obvious in some games than in others.
    In Watch Dogs Legion, the frame-rate will steadily drop from 30fps to what feels like 15fps (and even lower if you keep playing) after 90 minutes of play.
    In Immortals Fenyx Rising, if playing in Performance Mode (60fps), after an hour of play the frame-rate will start to hitch.
    In Watch Dogs 1, in Performance Mode (60fps), after an hour of play the frame-rate will start to hitch.

    Games where is is less noticeable (performance only starts to drop after about 3 hours of play) are Far Cry 5, Far Cry New Dawn, Assassin's Creed Odyssey.
    Other games I've not tested, or do now own on Stadia.

    The fix is always the same. Pause the game, then go into the Ubisoft Connect / Ubisoft Club menu. Let the menu load (it can take a few seconds), then back out of the menu and return to the game. Performance will be back to normal, and you can keep playing for another hour / 3 hours (depending on the game) before performance will start to dip again.

    Just to be clear:
    I've checked my connection - no problems there.
    Rebooted my router.
    Made sure my connection is wired.
    Made sure no other devices are on the network at the time.
    Tried playing on both Chromecast and Laptop.
    Other people in the Stadia subreddit have reported the same problem.
    The problem only affects Ubisoft games, and it affects all Ubisost games that I've tied. I can, for example, play Borderlands 3 or Destiny 2 for hours and hours with no drop in overall performance.

    As opening the Ubisoft Connect menu is the thing that always causes performance to recover, I really think its some sort of memory leak or build-up of data that only gets cleared when the Connect menu is opened.
    Any chance someone could look into this? especially with Uplay+ and more Ubisoft games coming to Stadia, it would suck if people found the performance to be sub-par.

    Thanks.
     1 people found this helpful
    Share this post

  2. #2
    I'm having the same issue, exactly as described.
     1 people found this helpful
    Share this post

  3. #3
    UbiExcellent's Avatar Ubisoft Support Staff
    Join Date
    Sep 2019
    Posts
    1,269
    Hi folks! I'm sorry to hear about these FPS drops and overall performance issues you both are having after extended play sessions via Stadia. Would either of you be able to supply a video that shows that accessing the menu then returning to the game improves the FPS as a temporary workaround to this issue?
    Share this post

  4. #4
    Oh wow, a response!
    OK, I'l try to capture a video, but please keep in mind this might be a bit tricky because of 2 things.

    1. Stadia captures are only 30 seconds long.
    2. The capture is recorded at 30fps, so games like The Division 2 (which run at 60fps on Stadia) dont really show the stutter in a 30fps video.
    Share this post

  5. #5
    Gah! I just realised that Ubisoft games now block the capture feature whenever you go into the Ubisoft Connect menu, so its impossible to capture everything.
    This is a very old capture, taken before Ubisoft started its blocking policy. Its not a great demonstration of the problem, because the difference is quite subtle, but it is there.
    Flick between the 6-8 second mark and the 27-30 second mark to get the best side-by-side comparison.

    https://stadia.google.com/capture/bd...1-e279f5186172
    Share this post

  6. #6
    I have a few captures here: https://we.tl/t-xXi37utiHR (WeTransfer link).
    It's usually not that bad at all, even if the game does run at 30 FPS nominally. First 30 minutes or so are much better!

    Edit: I should add, these captures were made server-side and are unaffected by the stream. They might also show as 60 fps in the player, because Stadia encodes things at 60 fps (it'll be clear that the footage isn't 60 or even 30 fps)
    Share this post

  7. #7

    Frame rate drop playing on stadia

    I have the same problem.
    Contacted Google stadia they say contact Ubisoft. The game quite often cannot be played.
    Share this post

  8. #8
    UbiExcellent's Avatar Ubisoft Support Staff
    Join Date
    Sep 2019
    Posts
    1,269
    My apologies for the lateness of my reply, everyone!

    ToyBrainS: Thank you for uploading this video link to this thread! I've added the clip to our team's on-going report about FPS drops on Stadia during long playthroughs.

    doublemp: I greatly appreciate you adding this link as well! Would you be able to upload the footage to YouTube, then provide the YouTube link here please? I wasn't able to view the footage due to the access having timed out, but this shouldn't be an issue with YouTube.

    djholland01: I'm sorry to hear you are also encountering this issue with FPS drops. Have you also found that returning to the main menu improves the issue as a temporary solution?
    Share this post

  9. #9
    Share this post

  10. #10
    UbiExcellent's Avatar Ubisoft Support Staff
    Join Date
    Sep 2019
    Posts
    1,269
    doublemp: These are perfect, thank you so much! I've gone ahead and shared these links with the development team to be reviewed further. Once I've received any updates, I'll share them with everyone here. Thank you all for your continued patience and understanding.
    Share this post